FEOA Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
ok so i gut my ultra clogged cat today...and put it on..my car starts workin woo woo ok, now i need to fix the fuel prob. it runs sooo rich it like misfires. and i got fire blwin out the exaust. braden said it is mostlikely my o2 sensor. he told me to get new one, and reset the ecu. anyone think it could be anything else?? thanks alot
 

·
Registered
Joined
·
1,346 Posts
I too am running richer then can be believed. I´ve taken "Rice-Burn" to a whole new level. I´m guessing its not my O2 because I just put a new one in, I´m actually thinking its my EGR.

Any thoughts ?
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #7 ·
wheres the egr valve? oh dont get me wrong the fire is cool as hell...i just need it to stop running like total crap from being so rich...pre-detonation from all the carbon build up sucks. it pops..you can here it poppin...and when the poppin happens is when the fire happenes...i saw somethin on here about adjusting the air/fuel mix with the vaf....is that applicable with a 91 egt? cause if so then damn ill go do it. and yes..braden is the man haha
 

·
Registered
Joined
·
277 Posts
Technically, you can adjust the vaf, but if that was really needed, something must really be wrong. i found that out the hard way. the problem may be the Throttle position sensor, or the air temp sensor. It may even be possible that your vaf took a dump and that you´ll need a new one. if you have like $25 to spare, pep boys, and i think even walmart sells a cheepie diagnostic tool thats come in handy for me. I ordered mine through JCWhitney, but they sell them all over the place
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top