wont start, no lights, only check engine | Ford Escort Owners Association (FEOA)

wont start, no lights, only check engine

Discussion in '2nd Gen 1991-1996 1.9L SOHC' started by brackaj33, Dec 1, 2012.

  1. brackaj33

    brackaj33 FEOA Member

    Messages:
    17
    Likes Received:
    5
    Trophy Points:
    153
    Location:
    Tualatin, Oregon
    Ok, turn key and only the check engine light comes on. No other lights. not even the seat belt retracktors move. It was driving fine, the after a quick stop at the liquor store it wouldnt do much of anything. I have checked the battery, the starter, any fuses, relays or fuseable links I can find, shut off switch, ignition switch, ignition cylinder and looked over damn near everything. What could I be missing?
    The BBE is a 1992 1.9 Pony
    (Bitchin' Blue Excort)

    Thank god it got me to the liquor store before it died.
  2. LeraiPalmer

    LeraiPalmer New Member

    Messages:
    156
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Milwaukee/Tomah, wi
    Hmm.. still sounds like an ignition issue. Check your battery cables and clean the battery terminals. That stuff can get corroded and u can still get a little bit of power but not enough to get the car going. Can you hear a click coming from the engine compartment when you turn the ignition?
  3. zzyzzx

    zzyzzx FEOA Member

    Messages:
    14,685
    Likes Received:
    1,079
    Trophy Points:
    463
    Location:
    Baltimore, MD USA
    :agree:

Share This Page