FEOA Forums banner
1 - 6 of 6 Posts

· Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
1994 5 speed LX 1.9. Just hit 200,000 miles. The car has been great but I've had times that the first time I turn the key nothing happens. Two or three times later the car starts up and is great. Now it's to the point where it won't kick over at all no matter how many times I turn the key.

Ok, here are the facts I know.

1) Changed ignition switch last week due to the same no start issue
2) Battery is good
3) Light under the hood is bright and strong
4) No headlights, dim dome light, no radio, wipers etc.
5) Fuel pump won't kick on.
6) Got some crazy noises from the block of electrics under the seat
7) "Clicking" noise from over by passenger dash
8) Main fuses under hood good
9) Inertia switch is good

The other couple times it's done this I've been able to push start it but not this last time.

It has had battery corrosion and I'm on my way to my stranded car to work on the terminals and batter cables. Any other thoughts as to what it could be?
 

· Registered
Joined
·
925 Posts
Try adjusting the clutch safety switch, under the dash. They have been known to slip through the threads on the retainer bracket, after YEARS of use.
 

· Registered
Joined
·
25 Posts
Discussion Starter · #3 ·
dave8338 said:
Try adjusting the clutch safety switch, under the dash. They have been known to slip through the threads on the retainer bracket, after YEARS of use.
Good thought, I actually have that bypassed as I hate that switch. But I checked that when I was going over my options. And I believe that if the clutch switch was the issue the fuel pump would still prime, and I'd still have lights and radio when the key was turned to "on" which I don't.
 

· Registered
Joined
·
6,057 Posts
i've been there thru 3 ignition switches and on my 4th one and my car is an automatic. i have found with my car that ignition switches die out due to the starter solenoid pushin out too much power. for me, that ended up with melted connectors at the starter and ignition switch. i'd say replace the starter. my car hasn't had any problems after i replaced mine. u should also use vaseline to keep the battery from corroding.
 

· Registered
Joined
·
25 Posts
Discussion Starter · #5 ·
I got it started and got it home after cleaning the battery terminals VERY well with a toothbrush and baking soda. How hard is it to replace both the battery cables? They're in pretty bad shape near the terminals but I don't have enough left to just trim off the bad and put on new connectors.

I bought both but they look nothing like the ones on there and the negative is at least is like 5 feet long and connected to a bunch of junk...
 

· Registered
Joined
·
6,057 Posts
my battery clamps where pretty rusted and i broke my negative cable clamp. so what i did was splice my battery cables from my crx into the escort and it works.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top