FEOA Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
k, so i got this escort from my dad, but the engine was blown, we went to the junkyard, got a 97 engine (I HAVE A 99SE) and put it in, seemed to work, but the engine was junk to begin with, knocks, ticks, torque converter leak, vacuum seal leak, i cant go into 4th gear without revving out the engine and can barely go up hills. i found a 96 or a 97 for parts that runs great mechanically, (i dont want to switch from my 99 because of the interior mods i have done already) can i just smooth the 97 or 96 in and have it work? or is there more to it? i know the mounts fit and all
 

·
Registered
Joined
·
9,941 Posts
What do you mean by "smooth in?" You can't put a 96 engine into a 99, it won't work right. A torque converter leak has nothing to do with the engine. It could be you just got a bad junkyard engine. Its best to grab an engine from a car with body damage because then you know it was working correctly before it got junked.
 

·
Registered
Joined
·
2,719 Posts
madmatt2024 said:
What do you mean by "smooth in?" You can't put a 96 engine into a 99, it won't work right. A torque converter leak has nothing to do with the engine. It could be you just got a bad junkyard engine. Its best to grab an engine from a car with body damage because then you know it was working correctly before it got junked.
Not necessarily

You don't want to go with a motor from a 96 cause that's a weaker motor.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
okay, ive already done the compression check, all is fine there, there is just no power, im guessing just an outright bad motor. i cant do more than 130 km/h going down a hill with my foot to the floor. or more than 80 up a hill, it just revs the hell out of itself, and im positive the transmission is fine (as it was an 80 XXX tranny swap before the engine went) anyways, the bottom line is, what CAN i put in that will work
 

·
Registered
Joined
·
9,941 Posts
Did you check the timing on the new motor?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #7 ·
my mechanic did the swap, and we checked everything before it went in, it looked fine, little beat up, nothing serious. i think the engine is just junk. ill just search for a 99escort parts car, obviously it will fit into my engine mounts and work quite fine
 

·
Premium Member
Joined
·
8,421 Posts
If the engine was "just junk" then the compression check would of showed low numbers.
If your compression is good then we know your rings are good and your valves are seating. So there is no good reason to be low on power (could be a cam/lifter problem, but easy to find).

You either have a sensor problem, or like madmatt said a timing problem.
 

·
Registered
Joined
·
9,941 Posts
That was my first though. If the compression is fine then something was overlooked during the swap. It could also be a clogged cat.
 
1 - 10 of 10 Posts
Top