What did you do to your 3rd gen today?? | Page 160 | Ford Escort Owners Association (FEOA)

What did you do to your 3rd gen today??

Discussion in '3rd Gen 1997-2002 2.0L SOHC' started by ndlm8888, Aug 2, 2013.

  1. copcarguy

    copcarguy FEOA Member

    Messages:
    1,978
    Likes Received:
    840
    Trophy Points:
    263
    Location:
    Northeast PA
    Today I put new outer tie rods on and then got an alignment.

    Oh, and checked my coolant level too...

    And then said a prayer to God to watch over the Tracer...
    ar154all and dchawk81 like this.
  2. catnapped

    catnapped FEOA Member

    Messages:
    232
    Likes Received:
    10
    Trophy Points:
    268
    Location:
    south central PA
    Scheduled inspection for early next week. Seems to be running pretty well since I put sealant on those vacuum tubes. Long trims are running a maximum of +4 now at idle and most of the time it's in the +1 to +3 range (was in the >+7 range previously).
    ShakeZilla19 likes this.
  3. ShakeZilla19

    ShakeZilla19 My name is ^^^

    Messages:
    3,150
    Likes Received:
    650
    Trophy Points:
    263
    Awesome, glad it was something simple.
  4. bigred98

    bigred98 FEOA Donator

    Messages:
    17
    Likes Received:
    4
    Trophy Points:
    103
    Location:
    Central Ohio
    Yep.
    Don't want to part with her!
    Needs much work, but....
    Best car I've EVER
    had!
    Gamer92 and copcarguy like this.
  5. copcarguy

    copcarguy FEOA Member

    Messages:
    1,978
    Likes Received:
    840
    Trophy Points:
    263
    Location:
    Northeast PA
    Today I swapped off my winter tires and wipers and installed Trico Neoforms front & rear.
    dchawk81 likes this.
  6. dchawk81

    dchawk81 FEOA Member

    Messages:
    3,450
    Likes Received:
    940
    Trophy Points:
    173
    If/when you do your inners, get Harbor Freight's inner tie rod tool. Makes quick easy work of the job. Even though it's $40, it's less than paying a shop...and you can do any car that has that style.
    bigred98 likes this.
  7. copcarguy

    copcarguy FEOA Member

    Messages:
    1,978
    Likes Received:
    840
    Trophy Points:
    263
    Location:
    Northeast PA
    I bought that tool a couple months ago... I used one of their coupons and got it for $29.99!
    DC Ultra likes this.
  8. dchawk81

    dchawk81 FEOA Member

    Messages:
    3,450
    Likes Received:
    940
    Trophy Points:
    173
    Lucky. I got it for $31.99 but by the time they taxed it and shipped it, it was $41.32.

    Problem is, the nearest store is too far away so it costs more than the $6.99 shipping to get there and back. It only makes sense to drive up if I want/need/can afford a bunch of stuff at one time, but I never do/can.

    Totally worth it though.
  9. catnapped

    catnapped FEOA Member

    Messages:
    232
    Likes Received:
    10
    Trophy Points:
    268
    Location:
    south central PA
    Unfortunately looks like I spoke too soon. While long trims are still 'passable' I'm back to seeing +7% at idle when the car's been run for awhile (30+ miles on a trip) so either the computer hasn't compensated that condition out yet or I didn't actually fix anything. May have to whip out the vacuum gauge and see if I can plug it in somewhere and hopefully figure something out.
  10. ar154all

    ar154all The Police never think its as funny as I did.

    Messages:
    1,002
    Likes Received:
    213
    Trophy Points:
    93
    Location:
    Florida
    cleaned it, full gas tank.
  11. DrewsBrews

    DrewsBrews FEOA Donator

    Messages:
    326
    Likes Received:
    137
    Trophy Points:
    103
    Location:
    SW Ohio
    Wish I could have worked on the scort. Just managed put the windows down for the day to air out some of the funk. Too busy prepping the mowers for the season and mowing 2 acres. Crunch time to get the veggie garden ready too.
  12. Tillerman

    Tillerman FEOA Member

    Messages:
    5
    Likes Received:
    4
    Trophy Points:
    3
    Location:
    Clarksville, TN
    I cleaned my IAC Valve (intake air control) and throttle body today. The carbon build up was terrible. Used 2 cans of intake cleaner and an old tooth brush and acid brush. It had a bad idle and kept dying. Runs good now and cost was about $7.00.
    copcarguy, 22732 and ar154all like this.
  13. 22732

    22732 Guest

    Messages:
    0
    Likes Received:
    0
    Trophy Points:
    0
    Took my wagon to the front end shop today to have them check it out/align it. He didn't seem to worried about the play in the steering rack and said it can be let go for a while longer. So the front end is aligned and in decent shape/handles better. However, the right rear wheel tow adjustment on the crossmember is completely rust frozen and can't be aligned properly anymore. And also one of my really nice S series alpine 5x7's in the rear blew out this morning. Pretty bummed about that
  14. copcarguy

    copcarguy FEOA Member

    Messages:
    1,978
    Likes Received:
    840
    Trophy Points:
    263
    Location:
    Northeast PA
    I hate when a speaker goes out! My RF Kenwood has been cutting in & out. I'm hoping it is the connection in the door, but I have found playing with the volume / on off button can make it come on sometimes... a project for the weekend I guess
  15. denisond3

    denisond3 Moderator Staff Member

    Messages:
    9,918
    Likes Received:
    2,681
    Trophy Points:
    563
    Location:
    south TX or northern VA
    I also have the 'want to unlike' pop up after I have 'liked' a post. I hit escape to back out of the page. It only happens to me when Windows 8 is the operating system. On the old laptop with the missing keycaps & windows 7 - it doesnt happen at all.
  16. catnapped

    catnapped FEOA Member

    Messages:
    232
    Likes Received:
    10
    Trophy Points:
    268
    Location:
    south central PA
    Had mine inspected yesterday, passed no problem. Was painting (rust converter) some of the surface rust underneath and see that the hose going from the big "Y" tee in the back to the charcoal canister is definitely deteriorating (computer not seeing it...yet) so gonna have to get some hose and replace that.
  17. F-16Wrench

    F-16Wrench FEOA Member

    Messages:
    658
    Likes Received:
    18
    Trophy Points:
    168
    Location:
    Broken Arrow (Tulsa), OK
    Cussed at it for making me have to splice a jumper wire from the IAT back to the computer. Was getting a maxed out voltage reading, meaning the signal wire was shorted to power somewhere between the computer and the sensor and stuck at -40 degrees, and I wasn't EVEN about to dig that wire all the way out from three different bundles just to find the short:sour:
  18. copcarguy

    copcarguy FEOA Member

    Messages:
    1,978
    Likes Received:
    840
    Trophy Points:
    263
    Location:
    Northeast PA
    Vacuumed it out. Checked the oil. Checked the antifreeze.
  19. 22732

    22732 Guest

    Messages:
    0
    Likes Received:
    0
    Trophy Points:
    0
    I changed the oil in mine today and found out that the passenger side fuel rail mount tab has broke off clean. I noticed it while it was running and saw that side of the fuel rail and pressure regulator vibrating. How in the world that happened, I have no idea. So looks like I'm going to have to look for a replacement fuel rail. Might try to jb weld the mount tab back on and see if that works.
  20. copcarguy

    copcarguy FEOA Member

    Messages:
    1,978
    Likes Received:
    840
    Trophy Points:
    263
    Location:
    Northeast PA
    I washed & waxed the wagon today. Then took the RF door apart to fix the intermittent speaker. The speaker adapter thing from Crutchfield rotted away. It kinda looked like the crap you'd get on a battery terminal. I had an extra one laying around from my Mustang I wasn't using so now that's fixed.

    Coolant in overflow tank is holding steady thank God.

    I did some research on the dropped shifter and found these on Mazda sites:
    http://mx-3.com/phpBB3/viewtopic.php?f=39&t=44745&hilit=anti drop&start=60

    http://www.clubprotege.com/forum/showthread.php?49894-shifter-dropped-through-floor-again

    So I ordered a bracket and I hope that'll work. Finding a new linkage is proving difficult.

Share This Page