FEOA Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a 2000 Ford Escort zx2. I was doing 60 on the highway and I heard this wierd saw/grinding noise and I felt the car about to stop. When I pulled over I saw white smoke coming from under the hood and the car would not start up again. I haven't had any overheating problems but before I had intermittent battery light problems even after buying a new battery. Could this be a problem with my starter, timing belt or alternator. I recently had the serentine repositioned at Midas because the alternator was not charging the battery. I really hope it's not the engine. Any ideas? :cry:
 

·
Super Moderator
Joined
·
6,053 Posts
remove the belt and try to start it. that will rule out all the accessories.

when it "wouldn't start" did it crank?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
It just makes a weird noise and won't turn over. When I was on the highway and tried giving it more gas, the car would not speed up at all. Could it possibly be the feul pump? And can a feul pump start smoking?
 

·
Super Moderator
Joined
·
6,053 Posts
is it still along the highway, or did you have it towed home? it doesn't sound too promising...
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
I had it towed home...still won't start. I'm gonna take it to a repair shop near my house and get whatever it is that needs to be fixed fixed.
 

·
Registered
Joined
·
63 Posts
ZX2Fast said:
White smoke could be the timing belt shredding.
BINGO this happened to mine you can remove the top cover and tell for sure . You will also find the timing is off too if its the timing belt. I put a timing belt kit in mine from Rockauto which included the idlers and tensioner. Hope this helps.
 
1 - 8 of 8 Posts
Top