FEOA Forums banner
1 - 20 of 23 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
On my 98 ZX2 I have a loud squeal/chirp that I thought was a bad belt(well the belt was bad just not this problem). Changed the belt, no luck. Got to checking, it seemed like it was coming from the alternator, changed it still making the same noise. It only happens when the car is warm. Very loud when it gets hot, but it will stop when I pulled the dipstick out or remove the filler cap. It is at the worst when the car is idling, sometimes at highway speeds, but not as bad. Got under the car last night and it is coming from the engine on the drivers side of the catalytic converter. I am thinking it is a vacuum leak, any other ideas:?:
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #5 ·
I changed it back in late spring but i will go ahead and change it agian they are cheap. :pottytrain5:
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #6 ·
Thanks for the help here but do you guys know of any other forums that I might be able to get some more ideas on this?
 

·
Registered
Joined
·
5,296 Posts
Did it do it before you changed the PCV the last time? My observation here is that if you remove the oil fill cap or dipstick and it stops, you've got too much back pressure happening in your crank case. Sudden pressure changes will cause a chirping sound. This concerns me as it's usually at a relatively high pressure before you hear something.

Another problem could also be exhaust components. I don't know about the ZX2, but on the second gen 1.9, there's a section of the downpipe that's secured by a brace attached to the oil pan. My brace had a hairline crack in it (barely even saw it), and when at idle would create a chirp as well. I'm wondering if there's a similar brace, even in another location that might have a crack in it.

Matt 8)
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #8 ·
I did not make the noise before I changed the PCV. When I remove the filler cap I can hear a whoshing sound (very high vacuum). If I cover the opening if the valve cover I feel a lot of suction the the noise will start back again. All this makes me think that I have a vacuum leak.
 

·
Registered
Joined
·
5,296 Posts
Sounds like your pvc is stuck open. There shouldn't be that much vacuum in your crank case at all. Try a new pvc first. If you take your old pvc out, you should hear a rattle when you shake it if it's in good working order.

Matt 8)
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #10 ·
I will replace it tonight. on a side note. I was under the car looking for the leak and 2 of the bolts on the bottom engine mount were almost off I could tighten them by hand 8O , the bushing were in bad shape. This is one of the 98's that vibrate, I have a copy of the TSB to help it , so I took it to the dealership and they quoted me $109 for the 2 bolts, 4 bushings, and 2 engine mounts.
 

·
Registered
Joined
·
5,296 Posts
click23 said:
2 of the bolts on the bottom engine mount were almost off I could tighten them by hand 8O , the bushing were in bad shape. This is one of the 98's that vibrate, I have a copy of the TSB to help it , so I took it to the dealership and they quoted me $109 for the 2 bolts, 4 bushings, and 2 engine mounts.
Captain Obvious to the Rescue :)

This would most definately cause a chirping/ rattleing sound.

Matt 8)
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #12 ·
No I tightened them up and no help. If it were the bolts how would you explain the noise stopping when I take of the oil filler cap?
 

·
Registered
Joined
·
750 Posts
alright captain obvious has a point, Yes that would cause a chirp/rattling sound(not tottaly right)BUT you have massive vacuum in your valve cover, Change the pcv valve, its cheap and if it doesnt rattle anymore (the pcv) then bingo there you go. And btw if you have all sorts of vacuum in your valve cover, why would you think you have a Leak, right there shows to me like a kinked line, or something. All because your pressure is building up, if you have a vacuum leak its usually accompanied by lets say a Hissing sound, not so much a chirp. Also your mount is mostlikely the rattling, if the bushings are bad then its moving more then it should. So get the mounts, and check the pcv, if thats not it. i do not know what it is.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #14 ·
Changed the pcv and no help( the old one rattled). The reason I think is a leak and not a kink is that the sound seams like is it come from the juction of the engine and the tranny. I have been having tranny problems(slipping), could the tranny be making the chrip, even though it does it in park?
 

·
Registered
Joined
·
5,296 Posts
Dah, I don't know why I didn't think about this earlier. Maybe because you got a ZX2, but on the 1.9's, and now looks like the zx's too, there's a pile of heat shielding around the catilytic converter just off the intake manifold. Try checking this out. It rattled/chirped like an S.O.B. unitl I removed it from my car. The spot welds that hold them in place rust out. Just nock/pry/pull/whatever to get them off.

Matt 8)
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #20 ·
I thought about that, but it seems the noise is coming from a small cavity there on the block its about 1x 2 in's and about 4-5 deep. it has a bolt at the top with what looks like an opening on the tranny side. :?:
 
1 - 20 of 23 Posts
Top