FEOA Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
475 Posts
Discussion Starter · #1 ·
ok.. i attached the radiator part of the cooler some 2 months ago, and got lazy, so i never connected the hoses...

im a lazy monkey, sorry

anyway.. today i got a rare burst of energy and i decided to finish it off, but the "universal" quick connecter was a terrible piece of crap, and it wouldnt fit into the car's radiator and leave enough area for the hose to bend properly(in more than a 3" bend)
so i got... creative... or pissed off, you choose.

i cut a 4 inch section out of the factory tube thinger and stuck the hose down about 2 inches on either piece then clamped it down
i made sure to clean all the little metal filings out, and added more fluid...
i also plan to change the fluid in about a week.(im paranoid when things work out too easily)


i was wondering if i did something foolish?
i mean i drove the car for a good 10 miles and no leaks...
it seems to be circulating fluid well and i even burned my fingers a little bit while testing the hoses and tiny radiator...


anyway another question.. if this all seems like a good idea to you all, should i write up a How-to, for intalling a tranny cooler? i mean it comes with directions... but they kinda suck lol


rAN
 

·
Registered
Joined
·
235 Posts
I don't think you will have any problems. It sounds awkwardly similar to my fuel rail setup ;) And if you have extra time, write up a how to, no need to stress over it, tho.
hehe, if it starts leaking let us know... atleast YOU won't need a fire extinguisher. :D
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top