FEOA Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter · #1 ·
so i couldn't find an rx7 VAF so i was tinkering around the junk yard the other day and found a non turbo 80's supra well the VAF looked exactly the same as the mazda ones so i grabbed it and the thing plugged right in. so i set the voltage to the same as you would the rx7 and it runs perfect. i did a search on this here and couldn't find anything about it so i thought i would let you guys know
 

·
Registered
Joined
·
65 Posts
You "set" the voltage....

Explain, please?

The supra has an AFM, not a VAF. The voltage output is ENTIRELY different. I'm honestly surprised your car runs right now.

Are you sure it's not just running open loop?
 

·
Registered
Joined
·
2,719 Posts
AFM's and VAF's operate in the same manner, flapper doors. Is it from a mk2 supra or a mk3 supra? mk2 == 1982-1986.5. mk3 = 1986.5-1992. If it was a mk2 supra I know where a butt load of those things are. I used to own one!
 

·
Registered
Joined
·
60 Posts
Discussion Starter · #4 ·
http://www.imazda.com/mazdaracer/RX7VAF.html
I did everything just as it were an rx7 VAF the voltage was closer to .61 instead of .5 it runs a little rich in the bottom end but helped a lot up top. it came out of an mk3 supra. this isn't the first time I've swapped sensors between Mazda's and Toyota's we put a 626 VAF on my friends turbo 4 runner without issue. everything plugs right in the only difference my friend and i have found is one says Toyota and the other says Mazda both are denso. i had to really loosen the spring in the Toyota sensor so it would open with the vacuum of the 4cyl. i need to tune it a little more but it runs fine.
 

·
Registered
Joined
·
65 Posts
silverton said:
AFM's and VAF's operate in the same manner, flapper doors. Is it from a mk2 supra or a mk3 supra? mk2 == 1982-1986.5. mk3 = 1986.5-1992. If it was a mk2 supra I know where a butt load of those things are. I used to own one!
Yeah, i know they operate the same way, but what i'm saying is that the voltage output at WOT between the two is VASTLY different.

I'd be curious to see when the Supra AFM triggers open loop on the BP motor.
 

·
Registered
Joined
·
60 Posts
Discussion Starter · #6 ·
it felt rich from 3k to 4500 and near perfect above and below those marks. so i just tightened the spring a little and it smoothed that up. it probably went into open loop at 3k and caused the motor to start dumping fuel early.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top