FEOA Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter · #1 ·
ok so here is my problem. i have a 92EGT 5spd I go out to start the car this morning and it fires right up i drive it down to the store and now it won't turn over not even a click. It push starts just fine. so i did get it home. My question is? are there any common issues with these starters/ignition switch/whatever else that controlls the starter. I want to check these before i go ahead and replace the starter. maybe i can save some $$$$$
Thanks
Ty
 

·
Registered
Joined
·
60 Posts
Discussion Starter · #3 ·
fuses are fine i'll have to give the starter wire trick a try i was going to jump it with a screwdriver but i couldn't reach it from above.
 

·
Registered
Joined
·
60 Posts
Discussion Starter · #4 ·
ok so i jumped it and nothing moved :( so i pulled it and $130 and some busted knuckles later i've got a remaned starter, but that wasn't the issue the ign switch connector is loose and i have to wiggle it to get the starter working. but the strange thing is that the starter tested bad as well so i would have needed one in the near future anyways lol
:p
 

·
Registered
Joined
·
60 Posts
Discussion Starter · #5 ·
and while i was under the car ifound out that someone had disconnected the coolant line that runs to the throttle body. and that my oil pressure sensor didn't even have a wire connected to it
 

·
Registered
Joined
·
60 Posts
Discussion Starter · #16 ·
Well the starter was bad haven't had an issue since replacing it. but i did clean all the connections on the starter, battery, and ign switch just to be sure.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top