FEOA Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I own a 94 lx and this only happens to me when i am doing freeway offramp butterfly ramp turns! while driving down the offramp at approx 30 mph i approach the end of the offramp and i press the gass pedal down to accellerate and the car acts as if its getting no gas its still running i believe and smoothly unfortunately i have my stereo too loud the 4 times this has happened i dont recall it happening on left turns only right i thought it was an issue with taking the silencer box out ie loosing air due to pressure or something but it has gotten worse even after i used my air chisel to poud a hole for my aluminum 2" spring tubing so i know its not a air problem but engine i noticed quite a performance increase(for an escort) with my homemade ram air mod this when i was mad at my car for stripping a wheel stud. anyway i recently replaced the fuel pump and plugs but not the fuel filter or wires i iwll replace it tomorrow and hope it helps any other comments please its quite the strange problem only happening on right turn off ramp butterfly style.
 

·
Registered
Joined
·
2,371 Posts
I have a 93 GT and have the same problem, it appears to be that on hard right turns (or just prolonged turns around 30+MPH) that the car won't get fuel. I believe it is due to fuel pump placement. I am looking into getting a second in tank pump to help resolve this problem, talked to a couple buddies who work for NAPA (one of whom races more than just "amateurly") and they both think that will solve the problem. Hope that helps.
 

·
Registered
Joined
·
5,296 Posts
I've said it a million times, I'll say it again. Never had the problem before. When I changed my fuel pump it happend on the on-ramps. It's the pulsator assembly between the fuel pump and mounting bracket. When in the turns the fuel exerts enough side pressure on the pump to cause the seals to leak. Either further securing the fuel pump (With a zip tie :roll: ) or changing the pulsator will fix the problem.

Matt 8)
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
are zip ties fuel safe? also my engine has been running rough could be the tranny though. It is a pulsating feeling through much of the car and noise it changes with rpm's
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top