FEOA Forums banner
1 - 18 of 18 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter · #1 ·
Well I am having trouble with my 2.0 SPI in my 94 LX. I have tried to trouble shoot it and have looked around for other posts but have found none. At this point I am thinking it is my TPS but I thought I would just ask to make sure. Here is what is happening:

At WOT the engine will bog after the secondaries open (set for 3000 RPM right now) now if I disconnect the secondaries and run it WOT the is no problem.

I have run the car with the TPS disconnected and with it connected and the engine seems to run the same...like crap above 3000. Thus I am leaning toward the TPS. Any one have any problems like this with their set up? Thanks.

Matthew
 

·
Registered
Joined
·
618 Posts
Well, I don't know much about the 2.0's, but I don't think it's the TPS, it just doesn't sound like the typical TPS problems that I've heard of. But since they're not expensive and they're easy to replace, you might as well replace it anyway, just in case. After all, I could be wrong. :D
 

·
Premium Member
Joined
·
8,421 Posts
Reset your computer one more time.

Tell me every thing about the parts you used, what injectors, fuel rail, FPR....
How old is you 02 seosor?
What TPS are you using?
You cant use a 91-95 TPS on a SPI TB with out rotating it. The key's are at a 45º angle from each other.
 

·
Registered
Joined
·
79 Posts
Discussion Starter · #7 ·
Update: The CEL comes on and the code is for a TPS Voltage too high or too low. Also the problem only exists when the engine has warmed up.

Jeff I just put on my new FPR and the new injectors and that part is working okay. (i.e. no change in the performance.)

And the TPS is from the 2.0 its not the one that needs to be angled.

Matthew
 

·
Registered
Joined
·
127 Posts
"No man.....S*&$ no man. I reckon a guy'd get his ass kicked for saying something like that."
It does my heart proud to know that there are as others like me wasting time watching movies......... :cry: thanks guys, you made me so happy.....
Anyway, back at the ranch.....can someone tell me what a TPS is in regards to a car? Throttle Position Sensor? Timing Position Series? Totally Pontificating Scholar? Please help.
 

·
Premium Member
Joined
·
1,675 Posts
I thought the secondaries are supposed to open at 3800 rpm? Opening them too soon could give you a flat spot in the power (bog) since there's not enough air velocity after the secondaries open at too low of an rpm. Just a thought.
 

·
Premium Member
Joined
·
8,421 Posts
91sleeper said:
I thought the secondaries are supposed to open at 3800 rpm? Opening them too soon could give you a flat spot in the power (bog) since there's not enough air velocity after the secondaries open at too low of an rpm. Just a thought.
Stock 3rd gen opens at 3 grand.
I can make them open at any RPM, it doesnt "bog" if open too soon or too late, just moves the power band around.
 
1 - 18 of 18 Posts
Top