FEOA Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
'96 lx with a 98 2.0l engine
check engine light came on, codes P0500, P1506, speed sensor and IAC valve
I have removed, cleaned and re installed speed sensor and connection,
I have also removed, cleaned and re installed the IAC and the MAF and added new spark plugs and fuel filter
The car now idles incredibly rough, chugs on acceleration and only smooths out after 2500-3000 RPM, car drives roughly no matter what gear.

What could the issue be? TPS? dirty EGR valve? gremlins who are bored and have no one else to pester?
 

·
Registered
Joined
·
6 Posts
I've been having the same problem..I've cleaned the EGR valve and no luck. It's still idling rough. TPS or IAC might be the problem, though for me, I think it's my Catalytic Converter as a Diagnostic shows the CAT has error codes. For you, it might not be the CAT. I'd suggest having a Diagnostic done.
 

·
Registered
Joined
·
48 Posts
My 99 Escort threw two codes for the same issue (two times) with the IAC and I removed it both times and soaked it overnight with carb cleaner. The IAC has a tendency to stick. After the second cleaning I had no more codes. But....I did notice the tiny vacuum hose under the throttle body was dry and cracked on the end and not snug with the body. Most likely a coincidence but it doesn't hurt to check it. I doubt it will remedy your "roughness"....sounds like something else. I've discovered the "roughness" with my car is NOT with the idle but with engine vibration, whether I'm sitting still or driving. Seems to be common.....
 

·
Registered
Joined
·
344 Posts
My stupid 98 Tracer/Escort threw up (lol) the same codes for the IAC before. I've replaced the IAC, replaced hose had it in a shop for them to find the cause and they didn't/couldn't find it either and today it still it idles like $hite. Although it gets better if I fill it up with petrol and drive it around for a while till it gets hot. Starting from cold it does not like at all lol. I think it's just these cars don't want to idle properly? When i bought mine it idled perfect had the motor mounts replaced and all of a sudden it idles like someone with a dose of the shakes from a hard nights drinkin!

I've given up trying to fix it I've just accepted that these cars are not exactly the best things ever made and will drive this thing till it either dies or until I can afford something more modern and with better millage.
 

·
Super Moderator
Joined
·
6,053 Posts
anyone replace the PCV valve on their car? mine was idling poorly and it helped. I don't remember the code I got, but it wasn't a PCV code it was something else.
 

·
Super Moderator
Joined
·
6,053 Posts
maybe :p
 

·
Registered
Joined
·
48 Posts
Nope, have not changed the PCV....seems fine... but I've gotten a check engine light for the IAC yet once again (three times now). It's too expensive to replace so I keep hitting it against the palm of my hand to free it. I've noticed the car runs so much better when the IAC actually sticks, no rough starts...no rough idle when I first put the car in reverse in the morning...less shaking at a stop light....probably because the idle doesn't drop down as low as when the IAC is actually working....just a theory.....
 

·
Registered
Joined
·
344 Posts
pextor said:
anyone replace the PCV valve on their car? mine was idling poorly and it helped. I don't remember the code I got, but it wasn't a PCV code it was something else.
Yes mine was replaced.. didn't do a thing for it! lol
 

·
Super Moderator
Joined
·
6,053 Posts
aidan80 said:
pextor said:
anyone replace the PCV valve on their car? mine was idling poorly and it helped. I don't remember the code I got, but it wasn't a PCV code it was something else.
Yes mine was replaced.. didn't do a thing for it! lol
I don't recall what the code was on mine, something about the idle speed to high or something, but replacing the PCV valve fixed mine right up!
 

·
Registered
Joined
·
344 Posts
pextor said:
aidan80 said:
pextor said:
anyone replace the PCV valve on their car? mine was idling poorly and it helped. I don't remember the code I got, but it wasn't a PCV code it was something else.
Yes mine was replaced.. didn't do a thing for it! lol
I don't recall what the code was on mine, something about the idle speed to high or something, but replacing the PCV valve fixed mine right up!
I had the idle codes as well.. replaced the PCV as the rubber was breaking down lol.. I had it held together for a while with just duct tape! Replaced the IAC, replace a hose line that had rotted but still it idles like crap. It seems to have good idle days and bad idle days lol

I'm still giving some serious thought to replacing this car. Still I'm thinking which I want more.. car payment or a terrible idle on an 11 year old car? The car payment looks quite good sometimes!
 

·
Super Moderator
Joined
·
6,053 Posts
I would keep the thing. it's paid off, the idle might be annoying but the car payments are more so!
 

·
Registered
Joined
·
344 Posts
pextor said:
I would keep the thing. it's paid off, the idle might be annoying but the car payments are more so!
True repo man is yet more annoying should I fall behind on payments! I'm sure it can't be fun to wake up in the morning and find no car there. Although I should be able to work my payments down below $200 a month by putting down a good deposit which isn't much more than I'm being robbed for healthcare I never use that they always find a reason not to pay for lol Least a new car I could use!
 

·
Super Moderator
Joined
·
6,053 Posts
true.
 
1 - 16 of 16 Posts
Top