Right turn signal issues | Ford Escort Owners Association (FEOA)
  1. Wash your hands and do not touch your face, keep it safe and clean. Long live Feoa!

Right turn signal issues

Discussion in 'Electrical' started by Itchigo, Jan 3, 2021.

  1. Itchigo

    Itchigo FEOA Member

    Messages:
    383
    Likes Received:
    121
    Trophy Points:
    193
    I'm having an issue with my right turn signal, it's NOT the bulb. It was intermittently working (like a bad wire), now it's not working at all. I have parking lights, it's just the turn signal that's an issue, the left side works fine. When I hit the turn signal to turn right the flasher flashes quickly (like a bad bulb), but the rear right doesn't go on at all. With the hazards, I only get the left side. In both cases the right indicator on the dash does not light up. If the bulb was bad this would flash very fast, I don't get any flashes, just the relay sound. The left side works as it should and flashes fast on the dash if I remove the bulb, simulating a bad bulb.

    I pulled the power steering reservoir, and the overflow tank to better see the wiring harness. The right turn signal wire to the bulb is GREEN/ W RED TRACER. I tried connecting this wire to direct power to see if anything got hot/blew. The rear right went on when I did this. This tells me I may have a broken wire, not a short. I stripped the black covering up to where the wires went into the bigger harness and didn't find any corrosion or evidence of a short.

    The next step would be a continuity test, but I don't know where the other end of the wire goes. I feel like I've rewired half the car because of my touchscreen and other mods, but I haven't messed with the turn signals. Well, except for the switchbacks under my bumper. They are tapped into the 3 wires going to the bulb but they've been problem free for 18 months.

    What would you guys advise?
  2. 87gtVIC

    87gtVIC FEOA Member

    Messages:
    458
    Likes Received:
    21
    Trophy Points:
    168
    Location:
    Whitestone. NY
    Is it possible the turn signal switch is bad/ the stalk ...and olny in the right position?
  3. Itchigo

    Itchigo FEOA Member

    Messages:
    383
    Likes Received:
    121
    Trophy Points:
    193
    It's possible that it's bad, but it moves properly. Last week I looked at it and got it to go on and off by moving the wires connected to the bulb. I retaped the wires and it worked for a day or 2. When I say retaped I mean the 6 inches of wires coming out of the bigger harness.
  4. Itchigo

    Itchigo FEOA Member

    Messages:
    383
    Likes Received:
    121
    Trophy Points:
    193
    So an update. I had a spare turn signal switch so I plugged it in (without installing it). No change. Next I pulled the right fender to check the wiring harness. The 3 t/s wires come 6 inches out of the main harness to go into the turn signal. Those 6 inches seem ok, no cuts or anything. The main harness looks untouched, it's still hung up properly and not hanging. I have 3 wires going to the right turn signal.

    Black- ground
    Red w/black - running light +
    ALL RUNNING LIGHTS WORK

    Green w/white- This should be the turn signal+ because the black should be the ground for running lights and t/s. However, I show this wire as grounded with my meter.

    So I'm guessing the green w/white is shorted to ground somewhere. I have no problem running a new wire, but where to look? Anyone got a schematic? I have a Chilton book, but that doesn't show me what I want.
  5. 87gtVIC

    87gtVIC FEOA Member

    Messages:
    458
    Likes Received:
    21
    Trophy Points:
    168
    Location:
    Whitestone. NY
    What year vehicle are you working on so someone can get you the correct manual?
  6. Itchigo

    Itchigo FEOA Member

    Messages:
    383
    Likes Received:
    121
    Trophy Points:
    193
    95 LX and thank you.

Share This Page