FEOA Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
My 95 LX hatchback has no defrost. I there a common problem with them? Also does anyone have any info on the automatic seat belts? Those also do not work and are stuck half way.
Thanks,
Derek
 

·
BYO Plastic cutlery
Joined
·
9,869 Posts
yup it's very common on the 2nd gens for the switch to burn up and melt inside. There was a thread on it recently. Make friends with your junkyard.
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #3 ·
Forgot to mention that I had already made friends with the junkyard and the other switch does the same thing. It will light up but wil not stay on. Is there a relay that may also go bad and if so where is it?
thanks,
Derek
 

·
BYO Plastic cutlery
Joined
·
9,869 Posts
I donno. I'm almost ready to guess not judging by the amount of heat generated in the switch. When you say it lights up but doesn't stay on, do you mean the button doesn't physically stay down or the button stays down, the light stays on, but the defogger is not on?
If the button won't stay down on its own it's bad. If that's what's happening try a third one.
 

·
Registered
Joined
·
513 Posts
I am not familiar with this heater circuit (ponies do not have rear defrost) but I would caution you.

If the switch keeps burning out due to excessive current draw there may be a problem with the wiring from the switch to the defroster. check for broken wires, bad connections, etc.

This should be looked into as it may be a fire hazard.
 

·
Registered
Joined
·
101 Posts
Hmm... mine has rear defrost, but everything else about it is like the Pony. But the switch won't stay down. I press it and it pops up again.
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #7 ·
ivanmmj said:
Hmm... mine has rear defrost, but everything else about it is like the Pony. But the switch won't stay down. I press it and it pops up again.
that is my problem. I push the button in and it lights up but when I let go it shuts off.
 

·
Registered
Joined
·
2,924 Posts
it will work if you hold the button down. mine does that too. not that big of a deal. there might be some sort of a clip behind it that would let it stay down but i havent bothered to tear my dash apart
 

·
BYO Plastic cutlery
Joined
·
9,869 Posts
I told you the switch is bad. There's a mechanical dohickey inside the switch with a spring that makes it so it alternates between held down and not held down. That dohickey is broken. It's very common. If you just got it at the wrecker then they'll give you another one.
 

·
Registered
Joined
·
373 Posts
Yeah it is definatley the switch, i have replaced them on both my escorts. I found that if you wedge something in the switch to make the light stay on your defrost will work but mine only worked like that for a while till it went completly bad. Just save yourself the trouble and go but a new switch, if you can get one.
 

·
Registered
Joined
·
4,662 Posts
Just do what I'm doing and rewire the circuit. It's a PITA but it will be worth it when it's done.
 
1 - 12 of 12 Posts
Top