P0457 and P0455 CEL | Ford Escort Owners Association (FEOA)

P0457 and P0455 CEL

Discussion in 'ZX2 1998-2004 2.0L DOHC' started by Kevin Rogerson, Aug 6, 2019.

  1. Kevin Rogerson

    Kevin Rogerson FEOA Member

    Messages:
    18
    Likes Received:
    1
    Trophy Points:
    3
    I have recently put a new head on my 02 zx2 and have had trouble with these codes. I have replaced the gas cap after the P0455 code. Today I got a P0457 code. I assume I have a leak in the evap system however I have no idea where to go next. I can't afford a smoke test as I live in a small town and the guy wants $150 to do one.

    I also don't know what lines go to what or where they are for the evap system. Can someone guide me through getting this resolved.

    Thanks.
  2. 4cylinder

    4cylinder FEOA Member

    Messages:
    669
    Likes Received:
    122
    Trophy Points:
    193
    Location:
    san diego, ca
    weren't you the one who changed the head because you were having vct codes?

    let's start with that, which "vct codes" were you getting?

    aren't you also the one who broke the exhaust cam twice after changing out the vct?

    did the cam and vct swap fix any of the problems you thought you were having? Other than the codes you have right now is the car running as it should?

    the codes you mention now are for evap leak. one of them is for evap leak at the fuel filler. You mention changing the gas cap, is there anything else you have changed or otherwise touched?

    answer these things so i have an idea what is going on and i will probably be able to pinpoint the source of the problem
  3. Kevin Rogerson

    Kevin Rogerson FEOA Member

    Messages:
    18
    Likes Received:
    1
    Trophy Points:
    3
    P0012 was the vct code

    The car runs with a bad idle

    The head was warped causing the timing retardation that is now fixed. It had nothing to do with how I was putting the cam in the journal nearest the timing belt was warped so it wouldn’t allow the cam to sit in correctly but it was such a small amount you can hardly see it. Nonetheless enough stress in the cam to snap it.

    I was able to track down a leak where my brake booster hose goes into the manifold. That is now fixed.

    I then also found two bad hoses that go into what I believe is the charcoal canister one goes to a small black T from the canister and from that T to the line that controls the heater and ac vents and temp.

    Those are all now fixed and it runs perfectly after an idle adjustment.

    I have no more issues it just took some perseverance to get the leaks tracked down especially when I had multiple leaks. Some of the hoses are wearing because it has sat for over a year. Slowly I am going to replace them all to avoid future issues.

    Thanks for your help!!!
  4. 4cylinder

    4cylinder FEOA Member

    Messages:
    669
    Likes Received:
    122
    Trophy Points:
    193
    Location:
    san diego, ca
    okay, great. good to hear it is all fixed

Share This Page