FEOA Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
145 Posts
Discussion Starter · #1 ·
Well, car was overheating today, never got this problem before, also the battery light came on... i was checking around and notice that there is no drive belt, the one that goes to the alternator... but car starts right up, no problems at all except for the temp deal. I want to think that is the thermostat or the missing belt( not very mechanicly inclined here), that i find a little bit odd. Any help will be great.
 

·
Registered
Joined
·
133 Posts
The battery light is coming on cause the car is running off just the battery.. and its overheating cause without a belt the water pump isnt working so no fluid is flowing threw the engine to cool it down. A belt is what u need.
 

·
Registered
Joined
·
2,719 Posts
noifwoao said:
The battery light is coming on cause the car is running off just the battery.. and its overheating cause without a belt the water pump isnt working so no fluid is flowing threw the engine to cool it down. A belt is what u need.
Wrong. Waterpump is ran off the timing belt, if the timing belt broke, the car wouldn't start. the serpentine belt runs the alternator, power steering (if so equipped), and A/C (also, if so equipped). If it's a new symptom, I'd say check to make sure that the fans are still kicking on and... could probably do with a thermostat replacement.
 

·
Registered
Joined
·
5,792 Posts
silverton said:
noifwoao said:
The battery light is coming on cause the car is running off just the battery.. and its overheating cause without a belt the water pump isnt working so no fluid is flowing threw the engine to cool it down. A belt is what u need.
Wrong. Waterpump is ran off the timing belt, if the timing belt broke, the car wouldn't start. the serpentine belt runs the alternator, power steering (if so equipped), and A/C (also, if so equipped). If it's a new symptom, I'd say check to make sure that the fans are still kicking on and... could probably do with a thermostat replacement.
Are you on crack. The water pump belt runs from the water pump to the altinator to the crank pulley. I get to pull all that crap apart this weekend because the water pump decided to start leaking.
 

·
Registered
Joined
·
2,719 Posts
I really should stop posting in the wee hours of the morning, LOL! I was thinking of the oil pump for some reason.
 

·
Registered
Joined
·
145 Posts
Discussion Starter · #8 ·
yeah, you guys are right, i got to work today and ask one of my coworkers and he told me the same thing... well, i replaced today , is a easy job if you know what are you doing... thanks for all of you that respond ... now tomorrow im bleeding the brakes of escort #1...
 

·
Registered
Joined
·
2,679 Posts
silverton said:
noifwoao said:
The battery light is coming on cause the car is running off just the battery.. and its overheating cause without a belt the water pump isnt working so no fluid is flowing threw the engine to cool it down. A belt is what u need.
Wrong. Waterpump is ran off the timing belt, if the timing belt broke, the car wouldn't start. the serpentine belt runs the alternator, power steering (if so equipped), and A/C (also, if so equipped). If it's a new symptom, I'd say check to make sure that the fans are still kicking on and... could probably do with a thermostat replacement.
maybe on a 1.9
 

·
Registered
Joined
·
2,719 Posts
actually, I had my friends dodge.... something or other on my mind. I was blown away when I learned that the waterpump was ran off the timing belt. AND, the fact that it was 2am and I was dead tired and had just gotten back from watching transformers. lul
 

·
Registered
Joined
·
145 Posts
Discussion Starter · #12 ·
No i didnt, well, my sister, she just got the car back home after it was overheating. And nobody else drove it till got fix.
 
1 - 12 of 12 Posts
Top