FEOA Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
hey all, had a small problem with my wagon this weekend. its a 96 wagon, and i just had my fuel pump die on me a couple of months ago. since getting it replaced, the car has shaken a bit at lower speeds, and doesnt seem to switch gears as easily (auto tran) with high delta g. i park on a sloped driveway, and this weekend, starting it up, it started, then, as i tossed it into reverse, jumped a bit, and died, leaving the car rolling down the slope. trying to restart it, it would start and die a few times, then after than, the starter was cranking nicely, but the engine would not catch. looking up online, saw someone who said they get their car to start if they held the gas down to the floor while starting. lo and behold, it worked after a few seconds, and hasnt stalled on me since, but engine seems to have even less power. im thinking that theres a problem, perhaps a small blockage or something in the fuel system. what do you all think, and how would i go about diagnosing it?
thanks.

(note, totally stock engine)
 

·
Registered
Joined
·
10 Posts
When is the last time you replaced the fuel filter? It is the most neglected part on many cars. Replace that first then see if there is any more trouble


If that doesn't work:

When the car runs you said it shakes, that can be caused by a dead cylinder.

Make sure your plugs are not fouled and ensure your plug wires are good. Also check for spark on each cylinder.

It sounds like a possible injector may have gotten clogged causing a dead cylinder. It may also be a Mass Air Flow Sensor (maybe).

Hope this helps.
 
1 - 5 of 5 Posts
Top