FEOA Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
10,892 Posts
turn the heat up full in the car in the cold, and see if it heats up at all. If it heats up, then it sounds like the blower motor! My Grand Prix had a clogged somethin tho.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
No heat at all. A/C has full charge...thinking on it though the compressor only comes....well...almost never.
 

·
Registered
Joined
·
8,446 Posts
Does your blower work?

Can you hear the A/C clutch engage?

Pop the hood and have someone select the A/C on while you listen for the clutch to engage. It should click. That will narrow things down a bit. Report back after that.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Nah I've done all that(forgive my with holding of info). The clutch has engaged maybe twice in the last 6 months (always at random). The blower works though, just nothing cold or hot comes out it just blows air.
 

·
Registered
Joined
·
680 Posts
Jared said:
Nah I've done all that(forgive my with holding of info). The clutch has engaged maybe twice in the last 6 months (always at random). The blower works though, just nothing cold or hot comes out it just blows air.
Did you check all your fuses?Is the passenger front carpet wet?I honestly think your blower motor under the dash is shot or your resistor.Check your connections to your blower motor and make sure they are tight.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
At work when I have an electrical problem the first thing I do is check the fuses connected with that system, but for some reason whenever I come home to work on one of my own cars I do not seem to think of that....not sure why. I guess coming home to work on cars after working on them all day just doesn't appeal to me. Guess thats the next thing to do is look over a wiring diagram and see which fuses could have blown.
 
1 - 9 of 9 Posts
Top