FEOA Forums banner
1 - 2 of 2 Posts

· Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi gang,

Been lurking for a bit. I come from the world of Miatas (yep, that 1.8l!), where I have 2. One CSP autocross car/summer street car & a '90 Spec Miata SCCA racer.

Just picked up a '94 Tracer Trio with only 54,000 on it for $1,600. It's in excellent shape & I'm using it as a daily driver for the commute. No doubt I'll stuff an intake & exhaust on it by Spring, but for now the only trouble seems to be an apparently sticking thermostat (heats on but the guage barely moves), and the mouse belts which are rather intermittent in working. I'll tackle the thermostat this weekend, but is there a trick to getting the belts to work better? It's been BITTER cold here in MI lately & I'm wondering if that has something to do with the connections.

Anyhow...thanks for any help, I'm sure you'll see me here a lot!
 

· Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Now fellas...I'm not here to start a fight! LOL It's definately acting like a switch gone bad. The belt is stuck in it's closed position now and seems to work a bit more often from the outside door handle, than the inside one. For now, I'll climb under it, but I'll check the switch when I get a free weekend to tear it apart.

FWIW, I hand an '88 1/2 EGT as well, my first new car...put 90,000 on it in less than 2 years!
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top