FEOA Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I'm pretty sure I know what the problem is, just want a couple of opinions.

Problem: after operating for awhile I come up to a stop and the engine is running rough and the battery charge light comes on (brand new alternator and it's working fine) and headlights "flicker". It only does that when in gear, sounds like it runs fine when in park or neutral. My guess is that I need to replace the EGR valve and/or the O2 sensor. Tune up probably wouldn't hurt either.

I checked some troubleshooting sites and that is what they said was more than likely the problem.


TIA.
 

·
Registered
Joined
·
8,446 Posts
The problem is not your O2 sensor or EGR valve. They are not in any way responsible for your charging system light coming on.

You battery light flickers or lights when you're out of the expected voltage range. Being undervoltage would also cause your lights to dim and could cause your engine to run like crap. Your problem is somewhere between the alternator and the battery.

Perhaps your alternator belt is loose. More likely, one of the connectors at the alternator is faulty. I had a bad connector once that only acted up periodically. I spliced in a new connector and haven't had a problem since.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Thanks high,

Battery and alternator are ok, found out that I had a loose connection which took care of the charge light and that it was a 2 part problem. I'll have to change out a battery cable come payday.

The guy at O'Reilly's probably said that changing the EGR, O2 etc. would probably do the trick on the rough idle when stopped problem. Unless y'all can think of something else that could be the cause of that problem.


Thanks again!!!!
 

·
Registered
Joined
·
8,446 Posts
Don't be too hasty. Change the battery cable and then drive the car for a week or two - your problem may be solved by then. If the rough idle doesn't go away (and it might not), get back to us then and we'll take another swing at 'er.
 

·
Registered
Joined
·
4,662 Posts
^^Agreed. Bad grounds will make your car run like......well you get it. 8)
 
1 - 5 of 5 Posts
Top