FEOA Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Well ill be buying a 93 escort gt and the engine needs some tlc. Question on it though when it starts up it idles at 3k rpms and when i push on the gas the rpms barely climb...3.1k...3.2k....etc it sat for about 4 months without being started and had a full tank of gas in it, just bad gas? suggestions?
 

·
Registered
Joined
·
2,596 Posts
i would start with a complete tuneup. change all the fluids & filters, plugs & wires.
probably fresh gas wouldn't be a bad idea. there's probably moisure mixed in with the gas.
and make sure everything's clean and debris-free.
i can't think of anything else..
 

·
Registered
Joined
·
2,596 Posts
James92Scort said:
EGTs should idle around 1400-1500 when cold and aroung 700-800 when warmed up.
well, that should be the case with every car on the road that functions properly.

that haggard civic i once owned idled at 2700rpms cold, and once she warmed up it was around either a rough idle of 400 or 1500rpms.
now THAT was a car that did not function properly.

_____________________________________
IDEA!
maybe the throttle body needs adjusting? or i could be barking up the wrong tree. but a suggestion never hurt anyone (i think).
 

·
Registered
Joined
·
1,170 Posts
well...maybe there is more.....

But...a tune up is always a good thing to start with

Check Engine Oil, Tranny Oil, Air filter, Spark plugs ( check for particular sign of engine malfunction...i can send you a pictures with several possible situation if you need it) flush your radiator and refill with clean 50/50 Coolant.... you might want to check your o2 sensor located in your exhaust manifold...you could also check for leaks in your intake system or in your pcv hose....could ....

if you want to clean your gaz line i know you can add Gaz line anti-freeze liquid (2$)....it will clean a little..or simply buy injectors cleaner..but its more expensive hehe..about 5 $

try to find any dammage parts in your engine bay and stuff...cauz 3000 rpms is pretty high....
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #8 ·
ok well i had the guy who owns it check the oil, radiator fluids and he said it would need an oil change soon and the radiator fluid looked fine, he also checked the plugs and said the 2 he could get off the tips on them were black( fouled?) and that there were some oil on the threads (valve cover gasket?)

Electronikal if i could get those pics from you that would be great.
my email is [email protected]
 

·
Registered
Joined
·
2,596 Posts
nos92mx3 said:
ok well i had the guy who owns it check the oil, radiator fluids and he said it would need an oil change soon and the radiator fluid looked fine, he also checked the plugs and said the 2 he could get off the tips on them were black( fouled?) and that there were some oil on the threads (valve cover gasket?)
okay, by the sounds of it; the plugs and wires need to be replaced as soon as possible. you can tell this by how he said he could only get two off - ive changed plugs & wires in my scort and had no issues pulling the tips. that's a result from age and lack of attention to the plugs.

and if there was something that i've learned about cars; it's that when it comes to most engine issues, black is bad.
when you check your fluids, if there is black or things floating around, they need to be changed and so does the filter. you can tell by either wiping the fluid on a white towel or rubbing the fluid between your fingers to feel for any grittiness.

-- that also means the plugs are old, worn, corroded, rusted, whatever.. they need changed also.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top