FEOA Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter · #1 ·
I have a 1993 Ford Escort automatic. Currently has about 45000 miles. Got this from my family business as a fixer upper / hobby. When it was given to us it has had low idol problems to the point of stalling out. I have recently done a full overhaul of the engine (Oil Change / Plugs / Wires / Fuel filter / Air filter / cleaned the Throttle body and air control valve) It still has a poor idle and now the fuel cut off light comes on after idling for a while but it still runs (horribly might I add). Im lost on what to check next. Or what I could have done to make it worse.

Thanks Jason :mad:
 

·
Registered
Joined
·
1,181 Posts
Had to change the MAF in my 91. It would low idle and eventually stall. It still likes to stall, but doesn't. I think that has something to do with the splice in the fuel sending line, (think the previous owner had a FMU on it....). It's also a Automatic.
 

·
Registered
Joined
·
74 Posts
Discussion Starter · #6 ·
Mines also a Automatic.. Finally got around to messing with this thing been traveling like crazy..

So Intake looks good No cracks.

And Fuel pressure is 30 PSI

Does that sound right? If so anymore ideas?
 

·
Registered
Joined
·
74 Posts
Discussion Starter · #8 ·
Jeffescortlx said:
You either have vacuume leak or a dirty/bad MAF.
Thanks yea im thinking Vacum leak.. Cause they are really crusty feeling.

and the bad MAF i cleaned it pretty good though not to say good enough.

Looks like im tracking down a leak.
 

·
Registered
Joined
·
74 Posts
Discussion Starter · #10 ·
zzyzzx said:
I was also going to say vacuum leak. get a MityVac and cheak everything. The PCV elbow is probably the most common spot though.

I've posted pictures of this particular part here:
http://www.feoa.net/modules.php?name=Fo ... ic&t=26196

You have to get a new one at the dealer, but they are not that expensive.
I did check that one it had a small crack in it so im having that replaced the plastic pipe felt and looked fine. as well as the Valve at the end seemed functional.

Question the Vacuum box can that be bipassed? is it functional? Cause i would rather just shorten hoses and cut it out. Thanks
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top