Electrical - My alt is bad | Ford Escort Owners Association (FEOA)
  1. Wash your hands and do not touch your face, keep it safe and clean. Long live Feoa!

Electrical My alt is bad

Discussion in '2nd Gen 1991-1996 1.9L SOHC' started by garyd, Mar 24, 2020.

  1. garyd

    garyd FEOA Member

    Messages:
    379
    Likes Received:
    19
    Trophy Points:
    278
    zzyzzx likes this.
  2. Gamer92

    Gamer92 FEOA Donator

    Messages:
    3,437
    Likes Received:
    985
    Trophy Points:
    263
    Location:
    Southern Indiana
    How are you testing the alternators to determine they are bad?
    zzyzzx likes this.
  3. garyd

    garyd FEOA Member

    Messages:
    379
    Likes Received:
    19
    Trophy Points:
    278
    I took it to both autozone and advanced auto
    Put on a machine and it failed at both places.
    Plus the 2l alt has a squeak/ chirp when spun.
    The one on the car The light came on and would not go out.
    Then it did and the car shuts off when bat is disconnected
    I thought my 2l one was good but decided to test it in case and I'm glad I did
    zzyzzx likes this.
  4. zzyzzx

    zzyzzx FEOA Member

    Messages:
    14,871
    Likes Received:
    1,147
    Trophy Points:
    463
    Location:
    Baltimore, MD USA
    Check the resistance where the brushes are as per the factory service manual. Or just pull them out and inspect.
  5. zzyzzx

    zzyzzx FEOA Member

    Messages:
    14,871
    Likes Received:
    1,147
    Trophy Points:
    463
    Location:
    Baltimore, MD USA

Share This Page