FEOA Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter · #1 ·
Hey, group!

I am very pleased to find this forum.... I have a catalog of problems with my car, nothing crippling but plenty irritating.

All ready, reading through the how to section, I've found lots of answers; even some answers to questions I had not thought of yet. Muy Bueno!!

I have cooling fan issues... I've recently installed the ubiquitous toggle switch to manually keep the temp down but your thread on the relays is great.

And I think I saw referance to improving the grounding? I have some of that going on right now... I have a ground wire clipped to the water manifold near the thermostat housing just so I can get a steady temp guage reading.

And I have the 'stalling lagging on corners with a low fuel level' issue... again, there is a solution in the "how to" section, of course.

I have other questions I'll save for another thread. Again, thanks for being here. I hope I can contribute here n there.

'94 Trio Wagon, 190k, auto a/c 1.9L
 

·
Super Moderator
Joined
·
10,294 Posts
Welcome to the forum. Like you, I have found useful info about things that hadnt gone bad yet on my car, but when I looked into it -- needed repair so they would Not fail me. Pre-emptive repair! I replaced my negative battery cable, and soldered to it all of the wires that formerly were grouped at the negative battery terminal & had corroded connectors. It made my temp gauge behave.
Now I also spray 80W oil onto the rusty areas under the back of the car, so the dreaded undercarriage rust wont spread, which I wouldnt have thought about without the forums.
 
1 - 2 of 2 Posts
Top