Low idle speed | Ford Escort Owners Association (FEOA)
  1. Wash your hands and do not touch your face, keep it safe and clean. Long live Feoa!

Low idle speed

Discussion in 'ZX2 1998-2004 2.0L DOHC' started by homestead367, Feb 17, 2010.

  1. homestead367

    homestead367 New Member

    Messages:
    516
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Indianapolis
    My car just started doing this last night. Last night I was driving home at night. Got gas my car tried to idle at like 400 rpm. I threw it in neutral and reved it up to save it from dying. Took my foot off the gas and the rpms fell that low again even in neutral. It did this 2 times last night.
    This morning it did something similar but not as low it dropped to around 600. Any ideas what the problem could be. IK with my lights on it strains the alternator but usually not that much.
    I am thinking vacuum leak, or pcv maybe. IAC? Any ideas? Comments?
    BTW my car has 135k miles on it and it is an automatic.
  2. fireguy

    fireguy New Member

    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    0
    Vacuum leak or loose ignition wires would be my guess.
  3. jermh1

    jermh1 Guest

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    mine did the same thing, it was a vac line inbetween the firewall and motor, towards the top. it was very small cracks in the line, so I just cut it back and it worked, hard as hell to find though.

Share This Page