FEOA Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter · #1 ·
Well my 95 gt has been very reliable but I am having a very odd issue I cant explain. My power steering belt sounds like its going to explode when motor isnt warm. It makes a loud whine noise when motor is not warm and then makes almost like a popping noise. It especially does it when I turn my heat on... and make a turn. Once motor is at normal engine temp noise is gone and no issues. It leaks nothing, belt looks brand new and shows no wear at all. Belt is tight not loose and I sprayed conditioner on power steering pulley with no improvement. I am stumped on this one. It hasnt affected driveability just really embarrasing waking up neighbors at 4am on way to work.
thanks for help
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #4 ·
are the alternator and power steering pump on the same v belt????
THat woukd make sense with the noise being much worse then. Dont know why a loud on the alternator would affect the belt and ps pump but oh well. Is replacing the pump a complicated job, seems like everything on this thing to replace is a pain in the butt.
 

·
Registered
Joined
·
5,229 Posts
The power steering belt operates the a/c compressor on the 1.8Ls. I had similar issue with my alt. belt, it had stretched and was "chunking" out causing strange noise at certain RPMs; loads. Make sure you identify cause before spending too much! A belt to eliminate the A/C only runs about $6. I don't run power steering currently because I need new pressure hose. I have had the A/C removed for several years now. See if noise changes with A/C on or off and make sure belt is properly tensioned and in good shape.
 

·
Registered
Joined
·
436 Posts
I am glad to see i am not the only one here with this problem. I was watching the other day the same thing happen. Both the PS and i am guessing the water pump are on the same belt. Bottom right side of the car for the water pump and and upper right for the power steering. right? Both clutchs when engaged make the pulleys stop dead to rights. Then when the clucths disengage they will spin freely. I am guessing that both PS pump and water pump will need to be replaced. Are you able to replace the clutch components on both pumps? or do you have to replace the whole unit.

One last ? I have no problem with over heating. It is only when the heater is turned on do i have this problem. Any ideas why?
 
1 - 8 of 8 Posts
Top