Electrical - Long Cranking | Ford Escort Owners Association (FEOA)
  1. Wash your hands and do not touch your face, keep it safe and clean. Long live Feoa!

Electrical Long Cranking

Discussion in 'ZX2 1998-2004 2.0L DOHC' started by Natcox64, Aug 3, 2020.

  1. Natcox64

    Natcox64 FEOA Member

    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    So earlier on here I had mentioned an over heating issue. Turned out to be a short. In fan plug about 4 inches back. Replaced plug. Now fans work. Replaced all fuses some were blown the 40 amp was blown. Went ahead changed the 2, 30 amp just in case. Also changed ccrm a while back. Actually before fan plug. So all this time been starting fine. Changed the plug. Sounds like a weak fuel pump or a short to the pump. Is there a way to test both. Will Stall out till pressure is good. Then runs fine. Any ideas before I spend a bunch on new pump. If I cycle key 3-4 times seems to do better. Just dont wanna spend money on pump if it's the plug.
  2. Swift

    Swift FEOA Donator

    Messages:
    535
    Likes Received:
    116
    Trophy Points:
    293
    When is last time you repalced fuel filter?
    zzyzzx likes this.
  3. Natcox64

    Natcox64 FEOA Member

    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Tbh I dont remember. But I've been around long enough to know it's either the plug or the pump. It started same times as the other elect. Issues.
  4. Joey_Twowagons

    Joey_Twowagons FEOA Member

    Messages:
    2,629
    Likes Received:
    1,251
    Trophy Points:
    413
    Location:
    Vancouver Island, Canada
    Temporarily rig up a fuel pressure gauge to the Schrader valve on the fuel rail to make sure that it's a fuel pressure issue.
  5. Natcox64

    Natcox64 FEOA Member

    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Not getting power to ect tried test light. No power in the wires behind the plug.
  6. Natcox64

    Natcox64 FEOA Member

    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Has new fuse and relay
  7. zzyzzx

    zzyzzx FEOA Member

    Messages:
    15,275
    Likes Received:
    1,246
    Trophy Points:
    463
    Location:
    Baltimore, MD USA
    For one thing, I always turn the ignition on and wait for the fuel pump to prime before I crank.
    Otherwise, how good are the plugs and wires?
    denisond3 likes this.
  8. 4cylinder

    4cylinder FEOA Member

    Messages:
    739
    Likes Received:
    138
    Trophy Points:
    193
    Location:
    san diego, ca
    2003 does not have this


    the problem is at the fuel pump. It is likely the fuel hose in the tank has a hole in it. This is common for this car especially at this age.
  9. Natcox64

    Natcox64 FEOA Member

    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Turned out to be a bad ground under the air intake somewhere. Now ground wire having to do with gauges, rpm,fuel, temp doesn't work.

Share This Page