FEOA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
750 Posts
Discussion Starter · #1 ·
ok my new escort, another 89 LX, has 31000 miles on it, so i was happy when my grandma told me this, (she just bought a ZX2), when i started it i heard the problem i didnt want, i dont know how to go about fixing the lifters. i know thats whats wrong, definitely a lifter tick. so whats the easiest way of fixing this...if there is one, and what kind of damage am i doing to my engine with this tick....
 

·
Registered
Joined
·
53 Posts
This may sound like a sad remedy, but I had a 89 and it had 46,000 on it when I got it. It sat for awhile before I got it, but my dad (a ford mechanic), told me to loosen the "rocker arms" use a little engine "lithium rebuild grease" on all the parts that rubbed, on the cam, arm, and top of valve stem, then torque it back down to specs, and it sopped it. I dunno if this will help you, but it did me.
Alex
 

·
Registered
Joined
·
57 Posts
I have the same problem..Is it like a constant ticking at idle? It s with me whether parked or stopped at a stopsign....... :-[
 

·
Registered
Joined
·
295 Posts
are you sure it wasnt 131k? Maybe you are right, but I know on my speedometer it only has 6 numeric dials.
 

·
Registered
Joined
·
750 Posts
Discussion Starter · #6 ·
i thought about that, but my grandma has the 2002 Zx2, and it has like 55 miles on it, and she never really drove far, so thats how i know it was only 31 thousand

and yes it is happens at an idle, my brothers boss, and my dad said it was a lifter tick, so i think it is
 
1 - 6 of 6 Posts
Top