FEOA Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
yesterday while enroute my escort died for no reason. I had it tow to the shop for repairs they said its getting fire and turning over good so its not the timming belt.They also said its getting fuel so could someone tell me why my escort is not starting or even sounding like it wants to start its a 99 zx2 escort with less than 90000 miles and was in great shape till this happened
 

·
Registered
Joined
·
10,892 Posts
I had that problem. Mine was getting fuel... just a bit much. Mine had a dead fuel regulator so it was flooding my engine. I'd see if they can read any codes that there might be on there. I believe that if you hold the pedal right to the floor it's a fuel cut off... try that when starting and see if that works. I could start mine when we did that, but it was difficult.
 

·
Registered
Joined
·
8,446 Posts
Where do you live? Condensation in the fuel could be a problem with colder temperatures.

If the crankshaft is turning and you have spark, a proper fuel mixture will ignite.

Pull the plugs, pour a little fuel into each cylinder, replace the plugs and try starting it.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
well tried the last subjestion and it didn't work but heres what the mechanic came up with they told me it has a dual cam and connected by belt and that it could be streched and cause it to be out of time and they are pulling the cover to check it out and he says its still showing no codes and getting fire and fuel but it won't start is it time to junk the escort and get a chevy ?????
 
1 - 6 of 6 Posts
Top