FEOA Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
125 Posts
Discussion Starter #1
sometimes my gas guage works and sometimes it dont. started having issues when did a engine swap. i even pulled the fuel pump every thing was free. it would be nice to work sometimes for a general idea on how much was left in tank. someone said it was a edis module?
 

·
Registered
Joined
·
428 Posts
My fuel gauge does not work accurate at all. I just use the trip meter as my gas gauge. I fill up every 275 to 300 miles.
 

·
Registered
Joined
·
107 Posts
91fordracecort said:
sometimes my gas guage works and sometimes it dont. started having issues when did a engine swap. i even pulled the fuel pump every thing was free. it would be nice to work sometimes for a general idea on how much was left in tank. someone said it was a edis module?
It is possible that the EDIS module is failing, or the contacts could be corroding. I seem to recall that it is located on top of the instrument cluster.
 

·
Premium Member
Joined
·
703 Posts
OK, to start with, the EDIS is located in the engine compartment on the left shock tower.

I will have to do some digging in the schematics I have but off the top of my head, I'm pretty sure it has nothing to do with your fuel gauges operation.

There is a small board that plugs into the back of your instrument cluster.
It's called the anti slosh board. It's only job is to keep your gas gauge from jumping all over the place when your driving over rough or uneven ground.

I doubt it would have anything to do with your gauge being inaccurate.

It either works or it doesn't.

You can check your gauge's operation and all the wiring from the tank to the gauge with a simple test. ( if you have the tooling to do it )

Your gauge should read near empty with approx 25 ohms resistance at the sending unit. The gauge should read full with apporx 150 ohms resistance at the sending unit.

IF you don't have a variable resistor to use for a test, you can get one at Radio Shack for about $9.00.

Take the wires loose from the sender and hook them to the variable resistor. Tuirn the resistor to the low end of it's travel. ( counter clockwise ) Use your ohmeter to check the resistance as you turn and watch your gauge while you do this. ( your ignition will need to be on )

IF your gauge is responding normally to the movement of the variable resistor, it and the wiring in the car are fine. In that case, you need a new sending unit in the tank.

IF you don't have a Radio Shack in your area and have no access to a variable resistor, then use your ohm meter and check the resistance at the sending unit. Use the figures above to determine what resistance you should expect to see based on how much gas you have in the tank.

IF your readings are off much, your sending unit is likely bad.

Don't neglect the fact that most erractic or eronious readings at the gauge are created by bad connections at the tank.

Have fun and keep us up on what you find.
 
1 - 4 of 4 Posts
Top