FEOA Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
I swaped a 2.0 into my 96 escort lx 2 yrs ago and now i am having probl;ems starting it in the morning. In order for it to start i have to give it gas while turning the key, and the idle now is rough and sounds like it will eventually will cut out but never does! Any suggestions on what to check?
 

·
Administrator
Joined
·
9,294 Posts
the first thing i would try just like the first thing that i check for all idle problems is the MAF. they dont last forever ppl. swap it with another one thats known good. ninet percent of idle problems with our cars are from the maf.
 

·
Registered
Joined
·
10,892 Posts
Once again, my stupidity, but where is the MAF, how much do they cost, and any pics??? I have a Haynes somewhere, but not with me.
 

·
Registered
Joined
·
8,446 Posts
You'll need a tamper proof torx bit (#20 I think) to get it off. Be gentle with the filaments and use plastic-compatible electronics cleaner.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #9 ·
So i checked the MAF sensor and it looked good, i also cleaned it with breakcleen it insure that it was clean. The problem wa that the starter wires were causing a spark to jump across and casing the starte to short out! Now the probem with the escort is that when i get on the gas (peadal almost all the way down) when the engine is warm that it starts to sputter and a little bit of backfire! Not when the engine is cold but after it warms up its starts to act up... Any ideas on what it could be? Misfire?
 
1 - 9 of 9 Posts
Top