FEOA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I just bought my first escort about a week ago and it was fine when I bought it and now its having some issues.

We know there is a transmission fluid leak, but thats the least of our worries.

The car shakes and sounds really rough in idle, but is fine when it gets going. The car is also getting the worst gas mileage I've ever seen in my life. My dads 94 F150 does better. I used a tank of gas in 4 days going about 60 miles!

The SES light is on, and we had the code check done and it came up P1506, idle air overspeed. So, we cleaned the IAC valve that was on it. No luck, so we bought a new one. Still, the evil orange light is haunting us. We can find no leaks in any of the hoses. Ive deleted the code and it keeps coming back, always P1506. Someone suggested changing the EGR valve?

What to do next?
 

·
Super Moderator
Joined
·
10,293 Posts
Maybe connect a vacuum gauge, to see what the vacuum reads at an idle, and while driving at a steady speed. You could try blocking off the EGR port, to see if that is a problem.
Checking whether the timing belt is off a tooth might be one of the things to check, or even just seeing if the timing belt is still snug and taut.
 

·
Super Moderator
Joined
·
6,051 Posts
replace the PCV valve.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Update;

Replaced the PCV valve. Light has gone off, but the car is still running funny.

Hoping for the best! Thanks for the suggestions!
 

·
Super Moderator
Joined
·
6,051 Posts
now get plugs and wires
 
1 - 6 of 6 Posts
Top