FEOA Forums banner
1 - 20 of 30 Posts

·
Registered
Joined
·
2,709 Posts
TitoElSpicco said:
95EsortSittinLo said:
correct me if im wrong but there is no interior
Exactly. That's why it's custom.
LOL spicco, you da man! I could be pimpin all teh hoz if eyz had dat setup, word!

And if you're into boxxorz, chexzor out my watercooled, 100% home-brewed jobbie:
<img src=http://home.twcny.rr.com/rensguns/caseradiator.jpg>
 

·
Registered
Joined
·
1,078 Posts
Discussion Starter · #7 ·
James92Scort said:
Sweetness man. looks cool and stripped out :)

I love the festiva, not to mention the kid flippin the bird. :lol:
Once i finish scraping all of the tarred cardboard out of there (i don't know what to call it.. it's like reeeeally cheap dynomat), i'm gonna sand everything down and just spray everything flat black so it's not a headache to look at. Then maybe one day, when i have $120 to blow, i'll get it tinted so no one knows it's gutted in the rear. Only downsides are 1. Highway noise is rather loud unless the radio is on.
2. The radio doesn't sound nearly as good without the rear speakers.
3. Chicks really DON'T dig it.
4. The rear end sits up 'bout 1" higher.

However, these are extremely minor problems compared to the major increase in acceleration. (From the cars i've raced so far, i would guess i'm around a 15flat in the 1/4)
 

·
Registered
Joined
·
1,078 Posts
Discussion Starter · #8 ·
siragan said:
And if you're into boxxorz, chexzor out my watercooled, 100% home-brewed jobbie:
That's hott man. And yes, i do wear boxxorz. I don't trust myself pumping water through my computer though. However, me and one of my buddies i work with (at OFFICE DEPOT, HOLLAAAA!!) have taken one of his computers (Pentium 533) and installed it inside of a small freezer (like a dorm fridge size one), which is reading right around -30*F. We've only had it running a day or two, but have safely overclocked it to 866mhz. We're having huge problems with condensation getting inside the freezer (the few times we've had it open). Another problem with the voltage regulators. :) Keep rockin' and a rollin'.
 

·
Premium Member
Joined
·
1,675 Posts
Nice. Looks like mine when I had a leak and had to figure out where it was coming from lol. If you wanna lose even more weight outta there then cut the spare tire well out and pop-rivet an aluminum sheet in it's place. Also, the carpet has about 5lbs of padding glued to it that you can rip off pretty easy and you won't even see/feel a difference once you put the carpet back in.
 

·
Registered
Joined
·
2,709 Posts
beav- it's just a loop I can grab on to to help pull out the empty bay cover out so I can access the molex connectors coming from the psu.
 

·
Registered
Joined
·
2,188 Posts
Heh.. homemade quick release :)

What cooling components are you using?

Have you read the Tom's Hardware How-to on water cooling?

I was going to build myself a phatty H2O cooled silent dual processor overclocked system.. but bought suspension wheels and tires instead. There's always upgrades. :wink:
 

·
Registered
Joined
·
1,078 Posts
Discussion Starter · #14 ·
ZX2rip said:
15 flat in the 1/4, What mods do u have done? 8O
half of my interior removed, k&n cone filter.
Other than that, it's pretty much identical to the way it came from the factory.
 

·
Registered
Joined
·
1,078 Posts
Discussion Starter · #16 ·
To haul more ace.
To save on gas.
To be easier on the clutch for daily pootin' around.
I also think it slightly improved my handing.

.. because unless you are trying to pick up women, or you're consistantly hauling 3 or 4 people, what do you need it for? It's useless weight.
 

·
Registered
Joined
·
126 Posts
There is no way ur running 15 flat with just those mods i would beileve mid to high 15's but 15 flat is damn quick. My SHO runs very high 14's to 15.2 and i have nearly double the hp u have. I know im hevier but it's still hard to beileve that ur running 15 flat with just those mods.
 

·
Registered
Joined
·
8,915 Posts
ZX2rip said:
There is no way ur running 15 flat with just those mods i would beileve mid to high 15's but 15 flat is damn quick. My SHO runs very high 14's to 15.2 and i have nearly double the hp u have. I know im hevier but it's still hard to beileve that ur running 15 flat with just those mods.
I'm guessing he's lost a good 300 lbs of dead weight there... A 2100 lb car with 130 hp is going to knock off more than a second in the et.

His car, i'm guessing, has a power to weight ratio of 16.15 lbs per 1 hp. where as a stock EGT runs 19.35 per 1 hp. That's quite a difference.
 

·
Registered
Joined
·
1,078 Posts
Discussion Starter · #20 ·
ZX2rip said:
There is no way ur running 15 flat with just those mods i would beileve mid to high 15's but 15 flat is damn quick. My SHO runs very high 14's to 15.2 and i have nearly double the hp u have. I know im hevier but it's still hard to beileve that ur running 15 flat with just those mods.
I have raced 2 SHO's earlier today as a matter of fact.
I know what SHO's run. I know what SHO's weight. I know SHO's.
My best friend is the leader of the Tidewater SHO Club.
1 Automatic '93 w/ a chip. We took off at 40 and he couldn't pull on me until 85 or 90.
1 Manual '95 which I myself piloted to a 14.60 @ 97mph. Bone stock, down to the air filter. I jumped him off the line, and stayed ahead until about 70. If this is the case, he would have crossed the 1/4 mark about 3 cars ahead of me, which would put me right around a 15.0.

Since you're running a high 14, you obviously have a 5speed. Keep in mind, your car is almost 1200lbs heavier than mine (if not more, since don't have AC). It's tire are not that much larger for launching that enourmous heap of a FWD beast. SHO's get, and i know that. But i get quicker off the line.

Look at the first page of my cardomain.com page. See the festiva? It was 60HP. You have close to 4x the hp of that mean machine in your SHO. Let's race 0-60. :)

You can call me out if you want, but my Escort has surprised a many a ricer. Keep on rockin' it out, and go easy on the SHO. I love those cars with all my heart. :)
 
1 - 20 of 30 Posts
Top