FEOA Forums banner
1 - 7 of 7 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a 1997 Ford Escort. My problem started out with the car acting cold natured. Trying to die when it was cold and progressively got worse.

Now it is running the fan and fuel pump with the key off and stops running them when we turn the key on. It idles rough and dies but always starts right back up and runs good for 5 - 20 seconds then starts all over again. If I kep messing with it and get it to run 45 minutes then it runs perfect like nothing is wrong. We took it and put it on a scanner it showed code po135 o2 sensor heater circut malfunction replaced the o2 sensor no improvements.

We have replaced the PCM, CCRM,(both from salvage yard) and the o2 sensor(new) .

Any help would be appricated. I am at my wits end.
 

· Registered
Joined
·
6,057 Posts
replace the ECT sensor
 

· Registered
Joined
·
6,057 Posts
oh, it idles rough when it's cold usually means the IACV is bad. BTW, on ur car, u should reset the ECU after replacing anything. that's the problem with OBDII
 

· Registered
1998 ZX2
Joined
·
9,978 Posts
Don't worry too much about resetting the ECU. If replacing a part didn't work then resetting the ECU isn't going to magically fix the problem. The IACV could be the culprit but that would not cause the fan and fuel pump to run with the car off. When you replaced the ECT you replaced the one with 2 wires coming out of it right?
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top