FEOA Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter #1
Hello everybody :)
I didn't post anything for a long time. Recently, after a period when my Escort run well, troubles started again.
It all started about 2 and a half months ago. I did my state inspection, and about a week after that escort was definitely not normal (it started before the inspection, except not on such scale). What happens, is that while driving, the car would jerk. Smooth acceleration is almost impossible, only with very gentle throttle. If gas pedal is pusched to the floor, the car jerks, hesitates, and sometimes makes a noise like a backfire/misfire/detonation/shooting_out_of_gun. It feels like the engine creates as much power as it can, but something is blocking the power from applying to the wheels.
After the state insp, when this problem was happening a lot, but not constantly, I changed oil (3000 miles). The problem completely went away. I went two days ago to Pennsylwania (from VA), which was about 1500 miles both ways, no problems on the way, and I got around 43-45 mpg @ 60-65 mph. After comeback, the car started jerking in next week after that. Now it jerks all the time for past two months. If anybody has ANY idea, suggestion, or hypothesis, please tell me so I can try it. Check engine light was on all the time, but looking for the jerking reason, I cleaned EGR pipe, and nice amount of carbon fall out. Now, check engine light comes from time to time. Codes pulled : 538 (KOER) and 542 (engine off). Neither one makes sense. Checked/replaced/100 % good and working: EGR valve, TPS, Fuel pressure regulator, Air filter, vacuum lines, sparkplugs, IAC valve, wires, coilpack, good quality fuel, fuel filter, MAF. Timing done about 30000 miles ago.
RPMs are about 1500 @ idle, drop to 1100, and then they usually stay at it. Sometimes they would drop to 650 with heavy engine vibrations only to go back up. The RPMs don't jump too much, but periodically it happens.
Exhaust from the engine to the end was replaced about a year ago, however there is a small crack in the noise absorber at the end.
Please, any idea appreciated.
Thanks :)
Oh, 1994 escort wagon, 180000 miles, manual
 

·
Registered
Joined
·
93 Posts
Discussion Starter #2
anyone? anything? i have to go to dullas airport this friday and I would be better knowing what's wrong.
 

·
Registered
Joined
·
15,318 Posts
Did you replace the TPS, or did you just check it, and if so how? Also post the descriptions of the codes.
 

·
Registered
Joined
·
93 Posts
Discussion Starter #4
I replaced my TPS (about 3 weeks ago), and cleaned the inside of the trottle. Nothing of the symptoms changed. I also checked the connector to the TPS; appered ok amond with the cable leading to it.
 

·
Premium Member
Joined
·
8,421 Posts
Any time I've had the jerking is because of a air metering problem. Either the MAF is sending the wrong signal (gone bad or coated with oil/dirt) or there is a bad vacuume leak, craked intake tube or intake gasket leak. Is the O2 sensor original?
 

·
Registered
Joined
·
927 Posts
Jeffescortlx said:
Any time I've had the jerking is because of a air metering problem. Either the MAF is sending the wrong signal (gone bad or coated with oil/dirt) or there is a bad vacuume leak, craked intake tube or intake gasket leak. Is the O2 sensor original?
Not to be picky but in addition to Jeffs' list I'll add Plug Wires/Plugs.

Otherwise these things in combination...
 

·
Registered
Joined
·
161 Posts
I'm still a noob when it comes to this, but maybe motor mounts?
 

·
Former Escort Owner
Joined
·
1,748 Posts
I don't think it'd be motor mounts. Those will be felt when accelerating, but they wouldn't affect acceleration by itself, or make any kind of noise. It's got to be something air or fuel related.

Casey
 

·
Registered
Joined
·
750 Posts
Code 538 - Brief wide open throttle not sensed during self-test or operator error
Code 542 - Fuel pump secondary circut failure
The first one is probably from not hitting WOT at just the right time.
Code 542 could be a short in the secondary circut, or the fuel pump relay contacts are always closed. It could also be a bad ground for the fuel pump.
Hope this helps.
 

·
Registered
Joined
·
6,096 Posts
mine does the same thing but it only happends when the tank is around a quarter full and taking right turns. it gets worse as the gas is being used and my feul pump makes a humming noise but it has been in since december
 
1 - 10 of 10 Posts
Top