FEOA Forums banner
1 - 8 of 8 Posts

·
Super Moderator
Joined
·
4,020 Posts
Discussion Starter · #1 ·
I went to the junkyard today and got the bigger maf housing and plus I got a gt grill and a rolly thing for the wagons ($20.00 for all) but back on topic, I noticed my hose was to small so I made it fit (streching) I had to change my ita sensor with my old one (plug didnt fit) and the maf had this strange little piece of plastic on the side of it so I broke it off and had to break the other clip thiny off too, I also had to turn my plug over and plugged it right in, did the reset on the ecu and fired it up drove it around for 25 min at regular idle to let it set and then I got down on it, wow talk about a little more ummph. any how our maf sensors are black and this one is a white/grey looking color. what I would like to know how is this thing working right????
 

·
Registered
Joined
·
15,619 Posts
sportscort93 said:
I went to the junkyard today and got the bigger maf housing and plus I got a gt grill and a rolly thing for the wagons ($20.00 for all) but back on topic, I noticed my hose was to small so I made it fit (streching) I had to change my ita sensor with my old one (plug didnt fit) and the maf had this strange little piece of plastic on the side of it so I broke it off and had to break the other clip thiny off too, I also had to turn my plug over and plugged it right in, did the reset on the ecu and fired it up drove it around for 25 min at regular idle to let it set and then I got down on it, wow talk about a little more ummph. any how our maf sensors are black and this one is a white/grey looking color. what I would like to know how is this thing working right????
Pics?
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top