Camshaft sensor installation on a 1993 Ford escort wagon 1.9L. | Ford Escort Owners Association (FEOA)

Camshaft sensor installation on a 1993 Ford escort wagon 1.9L.

Discussion in '2nd Gen 1991-1996 1.9L SOHC' started by Christopher J Coston, Sep 16, 2019.

  1. Christopher J Coston

    Christopher J Coston New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Has anyone on this forum installed a new camshaft sensor on a 1993 Ford escort wagon? It seems very difficult at first attempt. Please help if anyone can walk me through it. Thanks.
  2. denisond3

    denisond3 Moderator Staff Member

    Messages:
    9,845
    Likes Received:
    2,632
    Trophy Points:
    563
    Location:
    south TX or northern VA
    I answered this question elsewhere where you had posted it to me, asking I how I did it. You have to unbolt the intake manifold, and move it back away from the head. The sensor is held in with one bolt, and with the bolt out - you will be able to just pull the sensor out. Its got a longish snot, so its end can sense the flat spot on the end of the camshaft spinning past.

    Im curious why you need to replace it. Does the engine still run okay?

    Welcome to the forums by the way!
    zzyzzx likes this.
  3. Christopher J Coston

    Christopher J Coston New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Check engine light comes on rough idles then goes out when I accelerate. Had car stall at stop lights.
  4. denisond3

    denisond3 Moderator Staff Member

    Messages:
    9,845
    Likes Received:
    2,632
    Trophy Points:
    563
    Location:
    south TX or northern VA
    If a replacement cam position sensor helps with the CEL and stalling/rough idle, please let us know.
    zzyzzx likes this.

Share This Page