FEOA Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hey people how's it going so I have a 96 ford escort 1.9 engine and i was driving on a highway and then died on me i had no lights on wouldn't shift <it's an automatic> and crawl to the side of the road it turn over but won't start i pop the hood and saw white smoke everywhere around the engine but not a lot smell like burnt oil so i open the oil cap there oil there check the dip stick says full and clean not muddy call a tow while we hook up the car and got it back home I saw oil dripping so i pop the hood again and saw that oil is now all over my powers tearing tank any thoughts before i rip this thing apart yes it's
Motor vehicle Automotive tire Automotive exterior Rim Automotive design

not a Cosworth but its great on gas and still only has 137k miles so i would like to fix it
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
How many miles are on this engine?
I'm thinking dropped valve seat that punched a hole in the engine. Yes, I've had this happen.
its going to have to sit for now until the weekend its raining hard where i live and the car is outside then i will let you know more about it its just weird that is the only signs i saw so i know power steering is on its own loop and the oil didn't come out the block it would have been everywhere so i can only assume it came out the tank but my thing is if it was a drop vale i would had a noise in the engine i had nothing and i turn it back over several times it acts like it wants to start but wont i wounder if i have two issues i had a water leak a month ago so i put bar stop leak in just for a quick fix it stop and i believe it was the water pump that was the leak but then my thermoset got stuck open after a week driving the car so maybe the bar stop plug up my pc vale and thermoset of course i pull the vale cover off and i need to fix the water pump as well so i will let you know when i rip it apart
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #9 ·
so it was a nice day the rain stop so i drain the oil no metal just black and it looked like it wasn't enough oil i remember the light flicker on and off so i might have been low but the dipstick said full how long should the dip stick should be i might have a wrong stick and if it was low that could have cause it to shut off but it doesn't explain the white smoke and burning smell i do have oil all over the seal of the oil pain that could just be the gasket{ i pull the vale cover} no metal clean just black oil
Motor vehicle Wood Automotive design Font Auto part

i did drain the power steering tank it was power steering its just oil on the tank
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #15 ·
ok i know i haven't updated about my issue so this is what i know now i drain the oil and the pan felt light and my light was on when i did broke down but i pull the dip stick and it said full so i when i drain the oil and put fresh in i did pull that pan of the engine for 2 reasons one i wants to see how long this dip stick was and yes i believe its longer than what it should be so it just lying in the pan and even with 1qt of oil it would say full and the other reason was to check for metal again and a spun barring everything look ok so i closed it back up then i grab the compression test and pull the plugs so my plugs are black dry and suttee so that telling me maybe my engine is ruing rich so i did my test so my range it 140psi to 150psi so all chambers are fine now my check on 3 was smoking when i pull the tester out but the next day i did pull the plug after i crank it over a few times to see if it was still smoking it did not i also did a wire check to make sure i was getting spark to the plug even though they are fried i did change the power steering fluid yup its fluid in my tank but was burnt it was oil around my tank so now im checking if i get gas to my engine and waiting for the new dip stick from the dealer with the new plugs and wires even though my wires are good i decide to put out the cash and get new
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #16 ·
so, my new question is this i believe there is a fuel control unit somewhere on the engine where it is because i do believe she might be running rich and there might be a issue with that or maybe injectors and if i cant find a problem with that then well this ant like my classic with a carb on that i can control the air and fuel ratio so how would i adjust the mixture im hoping with the new plugs she will clean herself up
 
1 - 10 of 10 Posts
Top