FEOA Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
For a while now I have had this clucking noise coming from the front end somewhere. So last weekend I took it to the ford dealership and they looked at it. They said that everything looked ok and was tight. I know that my rear struts are getting worn down causing the front end to bounce a little more. But today while driving it sounded like something broke off and bounce and hit the underside of my car when I was driving, twice. While maintaning the same clucking noise. I find the noise coming from the driver's side front end but further in then were the outer CV joints is. I doesn't do it around corners just over bumps were my suspension moves alot. Also I think that when I brake while the wheels are turned to the left is makes the metal clunking noise. I sounds similar to a worn outer CV joint but way louder. I am going to the garage right now to jack it up and have a look see.

HELP ME

X
 

·
Registered
Joined
·
2,188 Posts
Check your strut mounts. Pop the hood and bounce up and down on the fender.. watch for excessive movement of the top of the strut. Then lift the car up and see how smoothly you can turn the wheels by hand. I've had popping strut mounts before that would only make a noise while turning and hitting a bump... eventually they were making noises all the time. It's just a guess though.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #3 ·
Strut mounts are fine. CV boots are good all around, exept for passenger side inner. I can see a ring of grease around from were it spins as the grease has been leaking. When I said big clunk I meant big as in metal get snapped of something, then felt metal bounce off ground then hit the underside of my car. When I check it everything looks good. I thought I would see something more than a little grease that had skirted out. There is not execsise play inthe CV joints. I don't know what to do???

It's gotta be something. All my ball joints and various end are good. WTH MAN. Streering arms look ok. Springs are fine.

Also I feel no lose of power or control when I drive. and there is no clunking around corners that have no bumps.

Jumps massive clunks on bumps. It's scary really.

Maybe I'll check the motor mounts, I dunno man.

X
 

·
Registered
Joined
·
160 Posts
Ive had a similar problem in the front end lately. Only my noise is a loud pop that only happens when I make a left turn. Im pretty worried about it.
Earlier, I had a clunk noise everytime I went over the smallest bump. Turns out, I had a broken mounting bracket on the rear swaybar. That wasnt so difficult to fix and now the clunk is gone. Check the mounting brackets for any of the suspension pieces if you can. Might help. Good luck.
If you find the problem, let us know what youve found....One of these days one of us is bound to hear the same noise in our car.
 

·
Registered
Joined
·
268 Posts
123

Sound like killed strats for me. They can make really strange noices when they are bad. When I replaced mine with KYBs I was in shock when I took stock ones out. You could slide the rod back in forward with 2 fingers on all 4 of them!!
 

·
Registered
Joined
·
1 Posts
I know this is my first post. I saw the problem and had to sign up to put my two cents in.... My 93 Escort was doing the same thing...clunking and all..and come to find out it was my tierod ends. I replaced them and didn't have a problem after that. Hope I could help
 

·
Registered
Joined
·
8,915 Posts
i have a question for you man...is it clicking when you brake and get down to around 10 mph? My car is doing that itself. I personally have no clue what it is. but I'm leaning towards CV joints and tie rod ends. my whole suspension is tired and old, so i don't know for sure anyway.
 

·
Registered
Joined
·
3,981 Posts
Loud pop when turning left. I know what that is cuz my right side did that, its call the axle housing. Trust me Ive had one snap before, get it fixed soon...
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #9 ·
sportscort93 said:
Loud pop when turning left. I know what that is cuz my right side did that, its call the axle housing. Trust me Ive had one snap before, get it fixed soon...
WTF is the axle housing? And what snaps?

I did hear some metal snaping/very loud clunk.

It is sure nice that you elaborated on that.

X
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #10 ·
James92Scort said:
i have a question for you man...is it clicking when you brake and get down to around 10 mph? My car is doing that itself. I personally have no clue what it is. but I'm leaning towards CV joints and tie rod ends. my whole suspension is tired and old, so i don't know for sure anyway.
It doesn't really matter what speed. And not always when I brake.

X
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #11 ·
Re: 123

AleX said:
Sound like killed strats for me. They can make really strange noices when they are bad. When I replaced mine with KYBs I was in shock when I took stock ones out. You could slide the rod back in forward with 2 fingers on all 4 of them!!
I am learning towards the struts because I know they are getting old. Problem I have is beleiving they would make such a horid clunk and something breaking sound.

X
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #12 ·
DirtyJim said:
Ive had a similar problem in the front end lately. Only my noise is a loud pop that only happens when I make a left turn. Im pretty worried about it.
Earlier, I had a clunk noise everytime I went over the smallest bump. Turns out, I had a broken mounting bracket on the rear swaybar. That wasnt so difficult to fix and now the clunk is gone. Check the mounting brackets for any of the suspension pieces if you can. Might help. Good luck.
If you find the problem, let us know what youve found....One of these days one of us is bound to hear the same noise in our car.
Rear swaybar, I don't think my car has a swaybar man!

Nevertheless, I check all mounting brackets and such and nothing.

X
 

·
Registered
Joined
·
15,390 Posts
I had this problem once. Never could figure it out. Even took it to a few places who acknowleged the problem but couldn't tell what it was. A year or so goes by and my engine throws a rod. While getting the engine replaced the mechanic commented about the noise while doing the test drive of the car and asked me if I had known that my front sway bar was very loose, and said that he had tightened it. Haven't heard it since.

I think the moral of this story is that you should check everything. Meaning your struts, strut mounts, inner and out tie rod ends, ball joints, sway bars, and anything else suspension related that I might have left out.
 
1 - 14 of 14 Posts
Top