FEOA Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hi,
I have a 95 Ford Escord Wagon with Manual Transmission with 125000 miles.

When i accelerate my car, my engine revs up but my car does not pick speed for some time....about 2-4 seconds. It feels as if the cluch is slipping. But once i am in 4th or 5th gear and rollin on an interstate, things are fine...only when i step suddenly on the accelerator or am in lower gears, i feel the slipping of clutch.

It may be due to a worn out clutch plate or some other problem like loose pressure plate or some other reason...If you had similar problem, can you let me know what may be the exact reason.

Also, if i need to change the entire clutch, how much $$ should i expect. If you stay near Chicago, can you lead me to a good transmission mechanic, i would really appreciate it.

Thanks a lot and Happy New Year!!
Regards,
Amit
 

·
Registered
Joined
·
795 Posts
Not sure what there charging up there. But around here to change to clutch, pressure plate, etc. You would be looking at $300-$400 parts and labor.
 

·
Administrator
Joined
·
9,286 Posts
James92Scort said:
Change the clutch, and while you're in there change the throw out bearing.
changing the throw out bearing is one of those things you just do. usualy its a good idea to repllace the TOB whenever the tranny is off. changing a clutch without changing the TOB is like drinking 151 without lime juice.

replace clutch disk and presure plate, TOB, Pilot bearing, get fly wheel resurfaced.re-bleed clutch.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
thanks...pepboys gave me an estimate of 550$ including clutch change, resurfacing and TO bearing change.

A month earlier, i used to hear a clicking sound when i depress the clutch way down. Could this be the TO bearing noise?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
I finally went to a place in Lafayette, Indiana where i stay and a reputed transmisison shop is doing my clutch for 485$.

But when i went for a test drive with the mechanic today, he revved up my engine soooo much, i had my heart in my mouth. He drove it upto 35m/hr in 1st gear and about 45m/hr in 2nd!!!!. When i opened the hood the engine compartment smelled like a rotten fish. He assured me that it was only the smell of the bad clutch.

Does driving a car with 125K miles at such high engine speed (for about 2 min) damage the engine? I really hope not!!!
 
1 - 7 of 7 Posts
Top