Amp/sub problem | Ford Escort Owners Association (FEOA)
  1. Wash your hands and do not touch your face, keep it safe and clean. Long live Feoa!

Amp/sub problem

Discussion in 'ICE (In Car Entertainment)' started by larrythecar, Jul 31, 2007.

  1. larrythecar

    larrythecar Guest

    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    0
    ok so heres the deal
    i just got a clarion amp and rockford sub so i decided i was gonna hook them up today
    i just spent about four hours hooking up all the wires and i am not getting sound or power to the amp

    could it be a bad amp?battery?
  2. zx24u

    zx24u Guest

    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    0
    make sure you have a fuse in the wire first...then make sure you positive and neg. speaker wire is hooked up right..
  3. larrythecar

    larrythecar Guest

    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    0
    fuse is in
    wire is on the positive
    speaker wire is in the sub correctly
    the only question is, there are two outputs on the amp "speaker A" "speaker B" does it matter which one i use

    the power light doesnt come on the amp so its not getting power..
    could not properly grounding make it fail to recieve power?
  4. mtlhead

    mtlhead Guest

    Messages:
    311
    Likes Received:
    0
    Trophy Points:
    0
    where are you grounding it to

    wheres the remote wire coming from?
  5. larrythecar

    larrythecar Guest

    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    0
    problem sorted out...
    thank you both
  6. mtlhead

    mtlhead Guest

    Messages:
    311
    Likes Received:
    0
    Trophy Points:
    0
    what did it end up being?
  7. bradsescort

    bradsescort FEOA Donator

    Messages:
    1,902
    Likes Received:
    2
    Trophy Points:
    298
    Location:
    in the pic above Pensacola, FL
    i bet he forgot to hookup the remote wire.. simple mistake and my first sub installation i did, this is what i forgot too.. basically a wire specifically from the headunit to the amp to tell it when to kick on..
  8. larrythecar

    larrythecar Guest

    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    0
    i had the remote wire hooked into the wrong blue wire in the deck... so i found another one tucked inside all the wires and that turned out to be it
  9. citrate

    citrate Guest

    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    0
    ahh yes the antenna wire vs amp remote mixup lol

Share This Page