FEOA Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
so I went to get an alignment yesterday. while Driving home from the alignment shop I imediatly noticed 2 things
1 the steering pulled to the right
2 moving the steering wheel just slightly to the left would cause the car to vibrate and make a loud humming/rumbling noise

so I bring it back in this morning , I explained the situation and I asked for a refund because it was covered under a warrenty. the guy outright refused to give me my money back unless they test drove it. and on top of that he claimed that it was already making that noise when thy test drove it before which I can tell you is a huge lie. long story short I cursed him out and stormed out of the place.

now I dont want to drop another 60$ on an alignment unless I'm sure that its the problem and so I once again I summon the help of my fellow escort enthusiasts

did these guys screw up my alignment or is something else wrong?
ps. balljoints and tie rods are all good so count those out
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #2 ·
just looked at the alignment report and realized they had the wrong car listed . the sheet says 98 escort ex. zx-2 but I HAVE a 95 escort lx wagon. dont know if it would mnake a difference or not
 

·
Super Moderator
Joined
·
6,053 Posts
sounds like he's not so welcome there anymore, zz.

take it somewhere else and pay the $60
 

·
Registered
Joined
·
9,941 Posts
Be sure to file a BBB report against them. The ZX2 should have the same alignment settings as your 95 but those guys obviously didn't know what they were doing.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
yeah maybe I should have let them test drive it to see how screwed up it was but frankly if they can't get it right the first time why should I belive they will the second time around? The car still pulls to the right, and I still can't see what would be causing it to but the more I think about it, the rumbling noise coming from the left front tire seems like it could be a totaly diferent issue. I'm not talking just a slight hum coming from the tire, when I turn left it sounds like the am=trak is passing by. since the bj's and tie rods are all good, I would imagine it is somewhere between the wheel bearing and the axel. I've been told that axels make more of a popping noise, so I'm going out on a limb and putting in a new wheel bearing. couldn't hurt with 160 k on origional bearings

- thanks for the feedback kepp the suggestions coming
 

·
Registered
Joined
·
2,679 Posts
the pulling to the right is probably from the guy either A. not doing the alignment correctly. or B. only doing a front end alignment instead of a 4 wheel.

as far as the vibrating goes though, idk.
 
1 - 7 of 7 Posts
Top