FEOA Forums banner
1 - 15 of 15 Posts

· Registered
Joined
·
712 Posts
Discussion Starter · #1 ·
Has anyone installed an aftermarket transmission cooler on a 3rd gen Escort? If you did, what did you use and how hard was it to install? Pictures would be awesome if you could get them! I think part of the issue with my transmission is it is overheating. I think the cooler in the radiator is restricted or clogged. I've had very good success on other vehicles with aftermarket coolers but I'm not totally sure how to install one on an Escort. Any input would be very helpful!
 

· Registered
Joined
·
93 Posts
hey man, i never used an aftermarket cooler, but why not just replace or flush your radiator if you think the trans cooling part is clogged? you can get a used radiator for dirt cheap, i just picked a new one on ebay for $29.99 shipped the other day. just my two cents. good luck with whatever you do
 

· Registered
1998 ZX2
Joined
·
9,978 Posts
dmitri15 said:
hey man, i never used an aftermarket cooler, but why not just replace or flush your radiator if you think the trans cooling part is clogged?
Because aftermarket trans coolers work way better than the one integrated into the radiator. I have never installed one but the idea seems simple. You just need to find where the cooling lines come out of the transmission, cut them off or adapt them to the hoses for the new cooler, then mount the cooler and run the lines to it.
 

· Registered
Joined
·
712 Posts
Discussion Starter · #4 ·
I found hose connections at the transmission but they seem a bit difficult to get to. I'm not sure how to run the hoses either. Once I figure that out, I'll think about putting one on. I don't think the factory in-radiator coolers are sufficient.
 

· Registered
Joined
·
119 Posts
Heres something you might try to improve your tranny issues. Add a bottle, 8 oz. I think, of LubeGuard in the RED bottle to your fluid. You might have to drain alittle. Around here its available at NAPA stores for about $10.00. I highly recommend it.

Be sure you get the RED bottle as there are others for different trannies.
 

· Registered
Joined
·
6,057 Posts
he said in another post that the transmission shop had put in a type of tranny fluid used for chryslers. and i don't even think adding "special fluids" will even help. i don't recommend using those special fluids that could do nothing but take ur money. just my 2 cents.
 

· Super Moderator
Joined
·
5,985 Posts
I threw a bottle of some for "trans fix" type of crap in my old 01 ZX2 that I bought with a bad transmission. I drove that car for over 10,000 miles, and by the time I sold it, the trans was BETTER than when I bought it. I can't say for sure that can of crap fixed it, but the transmission was almost 100% (had a weird shift between 1-2) when I sold it. one of those cars I "shoulda kept"
 

· Registered
Joined
·
119 Posts
juggalo said:
he said in another post that the transmission shop had put in a type of tranny fluid used for chryslers. and i don't even think adding "special fluids" will even help. i don't recommend using those special fluids that could do nothing but take ur money. just my 2 cents.
Check out what the folks say about LubeGard on Bob is the Oil Guy site. Very highly thought of, just my 2 cents.
 

· Registered
Joined
·
6,057 Posts
i still disagree with adding "special fluids"
 

· Registered
Joined
·
712 Posts
Discussion Starter · #14 ·
jcwit said:
juggalo said:
he said in another post that the transmission shop had put in a type of tranny fluid used for chryslers. and i don't even think adding "special fluids" will even help. i don't recommend using those special fluids that could do nothing but take ur money. just my 2 cents.
Check out what the folks say about LubeGard on Bob is the Oil Guy site. Very highly thought of, just my 2 cents.
Already ahead of you on that one! The converter would barely lock at all and after putting a bottle of Lubegard Red (from NAPA) in it, not only did the shifting improve, but the converter at least started to lock when it was cold. Once you drive it, park it, then drive it right away again, that's when it slips really bad now.
 

· Registered
Joined
·
24 Posts
Be prepared with some extra transmission fluid and something to catch some tranny fluid, because when you disconnect the original cooler on the radiator it will be filled with fluid. be sure to buy extra hose of the same kind that comes with it as they usually don't give you very much. you will need some good worm-drive clamps that fit the tubing you are using. if they are too big it might leak and could piss AT fluid all over. on the rad some of the transmission fluid line is metal and runs across the bottom of the radiator i just cut the original hose off of that and left the metal lines there. P.S. dont get the tranny lines mixed up with the AC. if you accidentally cut the AC line coming off the condensor, you're boned.

basically just mount the transmission cooler where you want it, and use the new hose to connect it to the fluid lines on the transmission. don't forget to clamp the hose to all fittings.

and if you take your intake and fan shroud off there is an amazing amount of room too work with to compared with them on

dont forget to recheck the fluid level after it's done and theres no leaks

oh, and sorry if it's hard to understand and if there's and spelling errors. i'm fricken tired.
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top