FEOA Forums banner
1 - 15 of 15 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter · #1 ·
Car 1995-GT

Well, like the title says, plus 2 major questions:

My A/C stopped blowing cold air a few weeks ago (accompanied by a loud squealing noise from the belts when putting the a/c on), I had a mechanic check the system and there was no pressure changes with the a/c on or off so he says the compressor is dead....

I need a new compressor (discontinued, remanufactured cost $350) and compressor clutch (about $180).

The main problem I'm faced with is that I can't even use my defrost setting on my vent or the belts start squealing... and its getting pretty damn cold now (-3 deg C today) so I'm going to need that setting soon...

1) Could it POSSIBLY be anything else....(please god....)
2) Any local boys (Ontario), "know where/can get/have for sale" the compressor cheaper

or....

3) Can I bypass the A/C for now(until summer when I have time to work things out), so I can use the defrost setting without the a/c kicking in? do I need a different belt etc... please be specific (95 EGT).

Thanks
Pat
 

·
Registered
Joined
·
1,477 Posts
Get a serpentine belt that is for your engine but tell them that you don't have a/c and you might be able to bypass the a/c pully (I don't know much about GT's). Also check eBay for another compressor I see them on there often but I haven't been looking for one so I cant remember which motor they were for.
 

·
Registered
Joined
·
105 Posts
Discussion Starter · #3 ·
Does anyone know if the 1.8L and 1.9L share the same compressor or are they different?

Also, if I put on the acc belt for 1.8L engines without A/C, is there an easy way to disable the a/c clutch from engaging when I put the vent selector to defrost etc..?
 

·
Registered
Joined
·
15,385 Posts
JimmyK1957 said:
The easiest thing to do would be disconnect the clutch wire at the compressor. That would keep the clutch from engaging.
I was also going to suggest this. My guess is that the compressor is different because it's a Mazda engine where as if it uses a Ford compressor it might be the same compressor used in all Fords for a number of years (meaning realtively cheap and easily available). Check NAPA and Car Quest.
 

·
Registered
Joined
·
10,892 Posts
Same thing happened in my Grand Prix, just disable the compressor clutch.
 

·
Registered
Joined
·
105 Posts
Discussion Starter · #7 ·
please....

trying not to sound clueless (but willing),... how do I disable the compressor clutch? is it at the compressor, behind the console?

I haven't had a chance to look at the problem yet since I'm busy studying like crap for tests/exams... but I should have a chance this weekend, so I'd like to try to get it fixed.

Thanks
 

·
Registered
Joined
·
2,709 Posts
There are two wires leading down to the pulley on the compressor. Follow them to a connector. Pull the connectors apart. It should take you about 40 seconds.
 

·
Registered
Joined
·
50 Posts
Hi

I got a 95 EGT compressor that I'm suppose to return as core when my compressor clutch died. The compressor shd be still good as it still held a charge and never made any noise before the clutch stop engaging one day, but the junkyard doesn't sell them seperate so I replace both of it.

You can have it for $10 or take it away free with my pentium 100 with 15inch monitor.

BTW, i'm in toronto

email me at [email protected]
 

·
Registered
Joined
·
3,307 Posts
Re: please....

Black_Knight said:
trying not to sound clueless (but willing),... how do I disable the compressor clutch? is it at the compressor, behind the console?

I haven't had a chance to look at the problem yet since I'm busy studying like crap for tests/exams... but I should have a chance this weekend, so I'd like to try to get it fixed.

Thanks
Hey man...glad to see that you didn't fall off the face of the earth yet :wink:

Anyways....just find where your A/C comp is in the engine bay....find the wire harness that goes down to the clutch....and either pull the harness off...or just cut one of the wires.

Done. the clutch will just free-wheel from there on in till you get a new comp from the junkyard or what have you.
 

·
Registered
Joined
·
680 Posts
One thought.check your accumulator relay.My a/c stopped blowing cold air and I tried recharging it and it would cycle on and off.They relay on top your accumulator is the culprit.
 

·
Registered
Joined
·
23 Posts
I have a '95 GT and my AC clutch went about 4-5 years ago. Same symptoms - no cold air - screaming squeal when trying to turn on the AC or defrost button. I had just the clutch replaced and everyting has been fine since then. Back then the clutch was a rare find - had to wait a few days for it to come in and there was also a core charge for the old clutch (so they can rebuilt them). It was a bit pricey but better than a whole new compressor/clutch combo. I work/live in the Burlington/Beamsville area.
 

·
Registered
Joined
·
105 Posts
Discussion Starter · #14 ·
just a bit of an update:
I disconneted the a/c compressor... but I still get my lights fading when I hit the a/c or defrost on - is that just from the rad fan running kicking on? . And occasionally the belt still squeals, but I figure that its just damaged from earlier.

CartCanuck - did it sound like the clutch was kicking at all? my mechanic said its sounded like the clutch was working, I just wasn't getting any pressure from the compressor.

Lukerw - thanks for the info... do you happen to know any cars with compatible a/c compressors?
 

·
Registered
Joined
·
465 Posts
Black_Knight said:
just a bit of an update:
I disconneted the a/c compressor... but I still get my lights fading when I hit the a/c or defrost on - is that just from the rad fan running kicking on? . And occasionally the belt still squeals, but I figure that its just damaged from earlier.

CartCanuck - did it sound like the clutch was kicking at all? my mechanic said its sounded like the clutch was working, I just wasn't getting any pressure from the compressor.

Lukerw - thanks for the info... do you happen to know any cars with compatible a/c compressors?
I have mine laying around I can sell you. I didn't swap it over when I did my engine swap. Still worked great when I took it off.
 
1 - 15 of 15 Posts
Top