97 Escort LX - HO Alternator? | Ford Escort Owners Association (FEOA)
  1. Wash your hands and do not touch your face, keep it safe and clean. Long live Feoa!

97 Escort LX - HO Alternator?

Discussion in 'ICE (In Car Entertainment)' started by D-Block1n, Nov 9, 2011.

  1. D-Block1n

    D-Block1n New Member

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Ssooo I got a pretty big stereo sitting in my room that needs to go in my ride, but that little stock 75amp alternator is definitely not gonna power two batteries plus 3200 watts of amp power.. I've found some 220amp HO alternators on Ebay for a pretty decent price, but the only problem is they say they fit either 91-96, or 98-02. Why the hell won't they fit on a 97, or will they? Does anybody know anything about this?
  2. neuspeedescort

    neuspeedescort Moderator Staff Member

    Messages:
    8,138
    Likes Received:
    101
    Trophy Points:
    363
    Location:
    wenatchee, wa
    it should fit your car just fine.


    NEUMAN
  3. D-Block1n

    D-Block1n New Member

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    I hope so.. I'm so tired of not having any boom! lol

    Alssoooo I saw another thread when I searched the forums about the aftermarket dash kits, but even after I looked through all 5 pages, I couldn't find an answer to my question.. I bought the Scosche kit and hooked everything up. I've done probably 50 headunit installs, so I have a little bit of experience, but never one like the Escort, where it has the climate controls
    & everything. My rear defroster no longer works.. Any suggestions?
  4. ShakeZilla19

    ShakeZilla19 My name is ^^^

    Messages:
    3,172
    Likes Received:
    666
    Trophy Points:
    363
    my defrost didnt work after i used the crutchfeild kit, I pulled it back out and wiggled the wires, and now it works lmao!
  5. D-Block1n

    D-Block1n New Member

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Yeaa i'm gonna pull it out one of these days when it's not 30 degrees outside... I'm hoping it's just something simple, like a wire came loose when I pushed the headunit into place.. But I've heard that other people had this issue as well, so I didn't know if there was a simple solution, or possibly something wrong with the wiring that comes pre-wired on the back of the kit.
  6. rebel4055

    rebel4055 FEOA Member

    Messages:
    429
    Likes Received:
    2
    Trophy Points:
    26
    Location:
    North Vernon, Indiana
    Some maybe all ebay brand alts that's out there most of the time doesn't put out anything it says it does. I would email either MechMan or DC Power seeing if they can do one for a 1.9. May be expensive but always worth it in the long run. Or http://www.singeralternators.com/

Share This Page