FEOA Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I was driving my 95 Escort about a week ago on the highway when the RPMs suddenly dropped to almost 0. I started to pull over when the RPMs came back up to normal and the car came back to life. Well...about 10 minutes later the car's RPM's were going crazy...bouncing up and down, the car was sputtering, could not go above 65 mph (with the pedal to the floor), check engine light came on, and the A/C went off. Got home and the car cut off as I came to a stop. Let my car sit a couple days then ran some seafoam through it...the check engine light went off, car idled normal, and A/C came back on. So I took it for a drive down the street...as soon as I got up to speed, the problem came back and the A/C went off again. I took it for a spin earlier and held the brake/gas at the light (so it wouldnt cut off) and the check engine light went off and car drove normal again for a second. Came to a stop and tried holding the brake/gas again...car went back to normal a second time for a second then the problem returned. I tried to do it a third time, but the problem wont go away anymore. Im kinda stumped about what could be causing my problem so if you guys have any guesses, that would be awesome.
 

·
Premium Member
Joined
·
703 Posts
First off you need to check and see what code your getting. That will tell you more about whats going on than anything.

Having a check engine light come on and the A/C stop working at the same time sort of leads to dirty or loose grounds.

Check your codes and let us know what your seeing
 
1 - 2 of 2 Posts
Top