1989 turbo escort still kicking after 3 years | Ford Escort Owners Association (FEOA)
  1. Wash your hands and do not touch your face, keep it safe and clean. Long live Feoa!

1989 turbo escort still kicking after 3 years

Discussion in 'Forced Induction & Nitrous' started by rix415, Sep 6, 2007.

  1. rix415

    rix415 Guest

    Messages:
    282
    Likes Received:
    1
    Trophy Points:
    0
    Been a while,

    took out my turbo motor/head and put in a stock motor in 2005?

    I got an RS setup with a SVO LA3 computer & sensors.

    plugs are white (eek) but i'm about to get it tuned up

    the compression is still 180-170 across the board.

    I'm going to dyno soon for a benchmark, then a tune - should be ~200whp by then. I'll keep you posted

    in the mean time i can only do burnouts in first gear :(

    enjoy,

    -Mark

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
  2. win0857

    win0857 FEOA Member

    Messages:
    1,117
    Likes Received:
    4
    Trophy Points:
    288
    Location:
    Connecticut
    Cool,another turbo 1st gen.What state are you located in?

    mark
  3. rix415

    rix415 Guest

    Messages:
    282
    Likes Received:
    1
    Trophy Points:
    0
    Michigan, south of detroit.

    how the hell are you pulling that ET?

    i should go to the track, i haven't been there since i put it all together in 2003.

    everyone usually laughs :)
  4. BOSS302man

    BOSS302man FEOA Donator

    Messages:
    2,665
    Likes Received:
    44
    Trophy Points:
    198
    Location:
    Lebanon, PA
    I'll take a wild guess, MI?
  5. win0857

    win0857 FEOA Member

    Messages:
    1,117
    Likes Received:
    4
    Trophy Points:
    288
    Location:
    Connecticut
    Yea,i get laughs also,but when i run side to side with a wrx or beat a duramax with BOOKU $$$$ invested it stops.Traction owns us front wheel drive's but 23 psi of boost helps!
    It's for sale as i am building a 88 and could use the $ for the "new"escort build!
  6. BTR-GT94

    BTR-GT94 New Member

    Messages:
    518
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Monroe, MI
    Where you at in michigan, i'm in Monroe.
  7. S-scort-Wagon

    S-scort-Wagon FEOA Donator

    Messages:
    1,267
    Likes Received:
    2
    Trophy Points:
    186
    his location... detroit area
  8. jamesm

    jamesm Guest

    Messages:
    1,085
    Likes Received:
    0
    Trophy Points:
    0
    you have LSD in that thing?
  9. neuspeedescort

    neuspeedescort Moderator Staff Member

    Messages:
    8,126
    Likes Received:
    98
    Trophy Points:
    348
    Location:
    wenatchee, wa
    good to see your still around!


    NEUMAN
  10. rix415

    rix415 Guest

    Messages:
    282
    Likes Received:
    1
    Trophy Points:
    0
    Im in taylor now.

    NO LSD, just got a new set of PILOT tires. They ran a little higher than normal but they hook up great and i can't seem to get a 'one tire wonder' burnout anymore unless i'm flying around a corner.


    think i might have just figured out why i might be having problems with leaning.

    im running the escort regulator instead of the 2.3L turbo ford regulator. At 0 vac our regulators sit at 38-40psi? after that its a 1:1 boost vs fuel pressure raise rate? I don't think our regs sit at 38 psi or have a 1:1 - i almost want to rig up the other regulator just to eliminate the possibility of it being different.

    going to miland dragway for test and tune soon, anyone wanna come? I don't think ill have time between now and then to fix the regulator but i want to run for fun. gotta beat my old goal of 16 seconds :)
  11. rix415

    rix415 Guest

    Messages:
    282
    Likes Received:
    1
    Trophy Points:
    0
    nevermind, just got back from the parts store - same damn regulator
  12. win0857

    win0857 FEOA Member

    Messages:
    1,117
    Likes Received:
    4
    Trophy Points:
    288
    Location:
    Connecticut
    Buy a after market regulator for a mustang gt.It is the same and bolts right up!!That is what i am using on the 86,i bought it on ebay.


    mark
  13. Jeffescortlx

    Jeffescortlx FEOA Member

    Messages:
    8,421
    Likes Received:
    13
    Trophy Points:
    338
    Location:
    Minnesota
    Good to see your still around and boosting that 1g.
  14. jigsaw

    jigsaw New Member

    Messages:
    1,803
    Likes Received:
    1
    Trophy Points:
    0
    wow, thats a nice car. it's rare to see a 1st gen where i live
  15. rix415

    rix415 Guest

    Messages:
    282
    Likes Received:
    1
    Trophy Points:
    0
    GREAT NEWS

    JUST GOT DONE INSTALLING THE WIDE BAND AND DIGITAL GAUGE AND ITS NOT LEANING OUT AT ALL

    14.7 ~ 15.1 idle and 12.8 up to 11..A/F!
    even seen a few 10's!!

    so - i don't know why the plugs are white. I'd guess there is some case that causes it - or a period when i had something messed up (its been 3 years).

    overall though I haven't had enough time to really understand its behavior completely but DAMN it is great to know your mixture with a decimal point!

    will try to get a video of a pull if i can tonight. I'm not sure what is to rich and what is to lean? i know i want 12.something and thats about it.

    im going to the dragstrip with my buddy tomorrow (with a car dolly) and try to get the ET down with some timing and boost (since i know im rich i can add some boost and/or timing)

    SO SLIPS TOMORROW
    (my 60ft is gonna be 3 sec)

    (im going to lapeer dragway around 4pm till like 8pm if anyone wants to show)
  16. 4doorscort

    4doorscort New Member

    Messages:
    8,129
    Likes Received:
    5
    Trophy Points:
    0
    Location:
    Brampton ON
    i'm not a big fan of 1st gens, but that things pimp!
  17. Jeffescortlx

    Jeffescortlx FEOA Member

    Messages:
    8,421
    Likes Received:
    13
    Trophy Points:
    338
    Location:
    Minnesota
    It has louvers, of course it's pimp.
    louvers = hotness.
  18. vtec-this

    vtec-this FEOA Member

    Messages:
    1,577
    Likes Received:
    6
    Trophy Points:
    288
    Location:
    Brampton Ontario
    what heat range of plug are you running? Stock heat range sure aint any good at 16psi.
  19. rix415

    rix415 Guest

    Messages:
    282
    Likes Received:
    1
    Trophy Points:
    0
    i need to replace plugs and wires.
    im not sure what to get, any suggestions?

    never made it to test and tune, turns out lapeer stops that at like 4pm - good thing i called before trailing out there.

    im running 5-10 psi (turbos so big it depends on rpm) now - thinking about just unplugging the wastegate line to see what it does

    since i couldn't get my fix i spent all yesterday pulling on and off sidestreets so i could see how fast i could pull from 0 to 45 (stupid laws) and i just couldn't get the tires to break loose on their own. i dont know if im just not putting out enough power or my tires are that good. its a crap shoot until i go to the dyno or the track.

    Think im going to buy a tweeker RT so i can monitor my computer and change the tables.

    had the car filled up with 6 gallons of 110octain so i started advancing the timing. got to little past halfway - i caught some deto (clap clap clap, about time) riding out first gear at 35-45. i need to return it to 10-12 BTDC and not do that again... ever..


    the la3 computer should put our over 200 whp. my A/F is actually a little bit to rich (when you think you should really be in the butter zone) it goes past 11.1 and into 10.9-10.5 (usually past 5000rpm)

    so, i think its gonna be a little bit longer till im making the power i can make. need to use real plumbing instead of pvc pipe and copper pipe fittings.. it just needs to be gone though again - and the mounting of my VAM is really bad - the engine vibrations must be messing with the reading (or so im told by everyone) - next month ill have some vacation time, see what i can pull out of it then.

Share This Page