FEOA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
119 Posts
Discussion Starter #1
So i got a 95 mercury tracer with a blown motor, Replaced the motor and it ran great, Besides the IAC which was replaced. Drove it for 5 months, Then got my ZX2 on the road, Then found out i don't want my zx2 because it was fix, drive, fix, drive. So i took out the tracer after sitting about 4 months. It started up great, But it "shakes" So i think it needs a IAC.. AGAIN! It also seems like it gets really cruddy MPG, I filled it yesterday.. Practically over filled it, and i put 40 miles on the full tank and im at 3/4's a tank. ALSO The car seems to have NO POWER, on the highway i have the car in 4th gear pushing that pedal down pretty far and still decreasing speed. then i get it to shift into 3rd gear around 4000RPM and the car shoots and speeds up quick. Is this normal? if so can i do something to the car for more low end power? It already has a Cold Air Intake. Let me know, This is my first 1.9L that was automatic... The 5-speed is much faster and responsive haha
 

·
Registered
Joined
·
149 Posts
To summarise;
1.tracer after sitting about 4 months
2.It started up great, But it "shakes"
3.gets really cruddy MPG
4.The car seems to have NO POWER

Add seafoam to the tank first.

Things to do..
Inspect Motor mount, clean MAF, O2 Sensor replaced?, Replace all suspected Vacuum Hoses, Inspect PCV and related tubing, Clean throttle body, Use OE plugs 1995 Motorcraft AGSF-34PP, AGSF-34FM / SP504, or Autolite APP5144
 

·
Registered
Joined
·
4,556 Posts
Do you have a check engine light? If the light is on get the codes checked and post them. We can be of more help if we know them. Check for vacuum leaks, especially the rubber elbows on the PCV line. Check the brakes to make sure none of them are dragging.
 

·
Registered
Joined
·
119 Posts
Discussion Starter #4
Check engine light is off, Cleaned the MAF and Throttle body, Replaced the IAC today (JY), No change, Has new plugs and wires, I'll check what brand the plugs are. I'll have to search for a vacuum leak. It is very shaky... Also the no low end power... I'll have to see if it improves with the new IAC. Thanks guys.
 

·
Registered
Joined
·
119 Posts
Discussion Starter #5
So i replaced the Idle Air Control and now the car runs great, It has power back, no shaking, and actually makes it up hills, Literally. But of course as an escort enthusiast im gonna still try to make it a little better, Was thinking about a better exhaust system for less restriction even though i don't race it.
 

·
Registered
Joined
·
2 Posts
i don't get how changing the IAC makes the car drive better. IAC would be for Idle right? maybe you fixed a vac leak or something unintentionally. my 1.9L used to bog while going up slight hills while in 5th gear. ended up being that the maf just needed a good cleaning. went through a full tune up to figure that out :p
 
1 - 6 of 6 Posts
Top