01 left turn issues | Ford Escort Owners Association (FEOA)
  1. Wash your hands and do not touch your face, keep it safe and clean. Long live Feoa!

01 left turn issues

Discussion in 'ZX2 1998-2004 2.0L DOHC' started by Josh Arnold, Jun 10, 2019.

  1. Josh Arnold

    Josh Arnold New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hello all, so I've got an 01 with about 215k miles on it. When I make certain left handed turns (not all) the car seems to shift. The RPMs will jump from about 2.2k to around 3.5 to 4k and I'll lose all acceleration. It'll stay this way till I straighten the wheel back out. I'm not getting any codes bit didn't know if I could be losing a sensor. Any clues?
  2. Joey_Twowagons

    Joey_Twowagons FEOA Member

    Messages:
    2,379
    Likes Received:
    1,095
    Trophy Points:
    413
    Location:
    Vancouver Island, Canada
    If the engine speeds up but acceleration is lost, it would seem that the problem can't be the engine. Is is a standard or automatic?

    If automatic, maybe the fluid is really low, and runs away from the pump pickup under a sharp turn.
  3. Josh Arnold

    Josh Arnold New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    It's an automatic. I'll have to take a look. Thanks for the info
  4. pextor

    pextor Moderator Staff Member

    Messages:
    5,932
    Likes Received:
    791
    Trophy Points:
    413
    Location:
    Lancaster, pa
    You don't hear any clicking at all do you? It kind of sounds like a bad CV joint.

Share This Page